Support » Fixing WordPress » 1.5.1 RSS issue

  • I did a handful of updates today, 8 of them appear to be fine.

    the 9th (of course, mine) has an issue:

    only wp-feed.php is returning with a feed.

    domain/feed/ (which usually works) is a blank page
    as are the other feed pages (even when called directly)

    I’ve tried:
    replacing htaccess with a fresh file (re did the permalinks)
    deleting the files and re installing them (ran upgrade.php again too, and it let me)
    deleting the files again and re installing them
    only deleting the rss related files and re uploading them.

    Is anyone else having this issue?

    I’m surprise that the other 8 are operating just fine, but this one is clunky.


Viewing 15 replies - 1 through 15 (of 37 total)
  • Moderator James Huff


    Volunteer Moderator


    This is confirmed: I simply posted something new and the /feed is working again as expected.

    However, now i notice that my comments are gone too…

    again, only on this blog (mine)

    what could have happened that would do that???


    Well I upgraded to 1.5.1 and posted and my feed has a ‘strtotime()’ warning in it and nothing else 🙁

    I had the same (blank page) problem. I changed the “Show the Most Recent” field to 1, made a new post, accessed the feeds, reset it to 10, then the feeds worked.

    Just had the same problem – creating a new post fixed it.


    That’s odd – just creating a new post didn’t do it for me. I had to change the feed settings as well. Just FYI in case creating a new post doesn’t work for someone.

    How did a bug like this make it through Q&A?

    Adding a new post didn’t seem to do anything, and so far neither has changing the feed prefs and adding a post. I’ll keep trying, but in the meantime, all of the 1.5.1 RSS feeds on my server are broken.

    I just upgraded to 1.5.1 too, and now all my feeds are dead. I access my feeds via domain/feeds (I don’t know where any rss preferences are located).

    Safari RSS notices that there is a feed available, but clicking on the little RSS only stalls the tab. It doesn’t actually go anywhere. I’ve tried switching permalink structures to index.php/… based ones from mod_rewrite ones, but so far I haven’t had any luck. I’ve also tried putting out new posts, all to no avail.

    EDIT: now it’s giving me this:
    Safari can’t open the page “feed://domain/feed/atom/�. The error was: “unknown error� (NSURLErrorDomain:-1) Please choose Report Bug to Apple from the Safari menu, note the error number, and describe what you did before you saw this message.

    Clicking on the feed link at the bottom just links me to an empty feed sheet (no postings at all)

    I tried editing a post and saving and my feeds came back – for awhile. Then they disappeared again. I tired posting something new – and they worked, but then failed again after a while. Lastly I changed the feed options – but that didn’t do anything for me. Anyone else have this issue – the fix working for brief amounts of time?

    Probably a stupid question, but… You all ran upgrade.php right?

    to running upgrade.php — yep.

    EDIT: on the WP dashboard, there’s a link to Owen Winkler’s page. I figure that since he’s on the dashboard, he’s probably pretty up on the functioning of WP. His feeds are busted too.

    Same problem. Writing a new post fixed the problem – afterwards just make a SHIFT-Reload with all Feed-Links to have the feeds show up again. Worked for me.

    what is a shift-reload, exactly? just keyboard commands?

    For those who are getting the “strtotime()” related error message, I think this is related to an error in the PHP code of WordPress when using PHP 5.0.4. I’m a new user of WordPress and after installing everything was working great except for the RSS feeds. This morning I downloaded and built PHP 4.3.11 and disabled 5.0.4 and now the feeds work and there is no “strtotime()” related error.

    BTW – If you are using Safari under Mac OS X 10.4 and you get the NSURLErrorDomain message that vinyl_warrior reported, I found that you can change the “feed:” part of your URL to “http:” and you will see the actual PHP error message that is being generated. In my case it was the “strtotime()” error message.

    Hope this helps.

    if i try to change feed: to http:, safari just changes it back.

    so far a new post hasn’t fixed anything for me.

    But for me, things WERE just fixed by following the help files advice and emptying my cache. **shrug**. Now things also show up in Newsfire, whereas they didn’t before. This is really bizarre.

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘1.5.1 RSS issue’ is closed to new replies.