Support » Fixing WordPress » 1.5 Comments Not Working

  • I know there are several other threads about this, but I went through them all and I really couldn’t seem to find what was wrong.

    Last week I upgraded from 1.3 to 1.5. Everything went pretty smooth, I had a template issues, but overall I got those fixed rather quickly.

    However the major issue I’m having is that all my comments junk stopped showing up, not only the “add comments” fields, but also the comments on my old entries, and the include is there for comments.php.

    Any ideas! I’m really at a loss here.

Viewing 15 replies - 1 through 15 (of 16 total)
  • This sounds exactly what’s happening to me. When you click on the comments link you get the post and nothing below it. No previous comments, no form fields, nothing.

    I’ve been through the upgrade instructions a dozen times and everything is just as the directions say.

    Apparently no one is going to be kind enough to help us sort it out.

    I’ll just have to be forever without comments.

    Have you checked out the PermaLink structure yet? I had problems with my comments, and fixed the PermaLinks structure to be:

    /index.php/%year%/%monthnum%/%day%/%post_id%

    The same thing’s happened to me, and I have absolutely no idea what’s going on. It’s really frustrating. I’ve gone back to 1.2.1 for now, if only because I couldn’t handle the lack of comments.

    I followed this upgrade 1.2 to 1.5 tutorial and it worked for me try it out

    http://www.tamba2.org.uk/wordpress/upgrade/

    Ginger I was actually upgrading from 1.3 to 1.5. So I had all my templates already fixed. So I should have been able to just do the upgrade that was included in the Strayhorn bundle. …

    I was having the exact same issue. See here:
    http://wordpress.org/support/topic.php?id=25867 and http://wordpress.org/support/topic.php?id=25806

    If you are not getting anything below the post when you click on the comments link, try changing your comments.php to one from the default theme. This will make your old comments show up and may fix your entire problem.

    However, I am still having the issue of the fields not showing up (i.e., Name, Email, http). http://brianpatton.org/ I can leave comments when I am logged in, so I guess any registered user could. This occurs on all themes, even ones that have not been modified.

    Any suggestions? Anyone? Please?

    bkpatton: Look at the source of your faulty displayed page in a browser…I see a wp-comments.php reference still in there for the form. Did you change index.php?

    @ Mikep, Yeah, I made all the changes according to the upgrade guide to my old template.

    However, my problem exists even in the pre-packaged default theme too. Thus ruling out any issues with the index or comments.php. And, if there is a wp-comments reference in there, I can’t find it.

    Bkpatton: Make sure you’re backing up the database regularly while this is sorted. There is a test WP 1.5 install at http://www.opensourcecms.com – look for CMS-Blogs and select WordPress – which is worth playing with. It’s something to do with being logged in or not.

    Your blog tells me this: “Logged in as . Logout ร‚ยป” Even if I do, the comment fields don’t appear when I go back to the blog. So look at login and cookie issues (does exactly the same in Firefox and Internet Explorer).

    Yeah, I noticed the “logged in” thing too. And it looks like any registered user can leave a comment, because that bypasses the form fields (Name, Email, http).

    I got an email from a person this morning who said they used phpmyAdmin to overwrite their existing comments table and it fixed the issue. However, as a result, they lost all of their existing comments.

    It would be nice to find a way to save the comments and get the fields back.

    Whatever you decide to do, back up the db first. Twice. And keep the copies safely on one side. Hopefully somebody out there reading this will give you an easy answer. All the issues I’ve had with WP1.5 have been one line edits. This may be another one (or maybe a setting).

    I tried deleting the wp_comments table from my database and recreating/repopulating it from my backup (.SQL file) — no dice. ๐Ÿ™

    Brian, the person who “fixed” it via the database … what did he/she do?

    Have you been to this thread yet?

    http://wordpress.org/support/topic.php?id=23507

    Padre, I so love you. ๐Ÿ˜€ After a little tinkering that fixed ’em!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘1.5 Comments Not Working’ is closed to new replies.