[resolved] 1.4 bugs (5 posts)

  1. rrhobbs
    Posted 2 years ago #

    The Google Sitemap, nor the robots.txt excluded posts features seem to be working in 1.4. The Google Sitemap is blank and Google Webmasters Tools reports a parsing error:

    XML Parsing Error: undefined entity
    Location: http://website.com/sitemap.xml
    Line Number 4, Column 127543:<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9" xmlns:image="http://www.google.

    Checking the plugin's robots.txt box has no effect on the output of the robots.txt

    I have tried saving a post as well as deactivating / reactivating the plugin, saving the sitemaps manually. Using WP 3.5, upgraded from 1.3.3

    The php errors in 1.3.3 are fixed.


    Retrograded back to 1.3.3 for now, everything works as before.

  2. Luigi
    Plugin Author

    Posted 2 years ago #

    Hi, I replied in the blog.

    If you excluded some pages/posts from the Sitemap, in the post just published I described how to get the exceptions back.

  3. rrhobbs
    Posted 2 years ago #

    I don't have the time or wherewithall to restore the table data I lost upgrading; I'll be manually re-tagging all those posts (100?)

    The 1.4.1 Google Sitemap didnt work, even disabling the image sitemap

    Since it generally works with fewer complications, I retrograded back to 1.3.3 - it is easier to occasionally delete the harmless php errors it generates for the time being.

    Thanks for your hard work all the same.

    Feature suggestion for future release:

    Option to detect no-indexed posts, pages, categories, tags, post types and bulk / automatically remove from sitemap(s)

  4. Luigi
    Plugin Author

    Posted 2 years ago #

    The alternative to manually set all the exceptions is to restore the data from a database backup.

    So far, I have not encountered problems with SiteTree 1.4.1! What is the problem you are experiencing? Could you post (or send me) a link to the sitemap with SiteTree 1.4.1 installed?

    About the feature you are suggesting: how did you set the noindex meta tag?

  5. rrhobbs
    Posted 2 years ago #

    >>> About the feature you are suggesting: how did you noindex(ed) the posts and pages?

    <<< WordPress SEO

    I understand that the database backup could be used. I will wait till the plugin is ready for for auto-installation before I upgrade.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SiteTree
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic