Support » Plugin: Yoast SEO » 14.0.4 – database error

  • Resolved alex586

    (@alex586)


    HEllo,

    After the update (same error with .2/.3), I have an error :

    Yoast SEO was unable to create the database tables required and as such will not function correctly.
    
    Please read this help article to find out how to resolve this problem.

    I uninstalled the plugin, nothing change.
    Thank you

Viewing 10 replies - 1 through 10 (of 10 total)
  • I tried rolling back, installing the helper test plugin… nothing removed the error. Hosting provider claims there is no issue with the database. getting ready to uninstall yoast myself.

    Maybe same error as me (I have it on the staging site, hence “wpstg0_” prefix instead of “wp_” in table name:
    https://wordpress.org/support/topic/13-5-14-0-4-upgrade-error-wpstg0_yoast_indexable-already-exists/#post-12771999

    Thread Starter alex586

    (@alex586)

    Tried to uninstall and manual install from the Zip. Nothing change.

    I also tried YOAST test plugin, nothing change.

    • This reply was modified 1 year, 7 months ago by alex586.
    • This reply was modified 1 year, 7 months ago by alex586.
    • This reply was modified 1 year, 7 months ago by alex586.
    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We are sorry to hear that you are having an issue with the Yoast SEO plugin, and we’d be more than happy to investigate the matter further for you.

    Yoast SEO v14.0 comes with the new indexables features that include some new database tables. When Yoast SEO plugin can’t create the relevant database tables correctly, it throws an error. To investigate the issue further, would you mind to answer and perform the following steps?

    • Can you please confirm that Yoast SEO plugin has enough permission to write on your site database? If you are unsure about this, please reach out to your web hosting provider for confirmation.
    • Can you please confirm whether your site database has the following database tables on it?

      wp_yoast_indexable, wp_yoast_indexable_hierarchy, wp_yoast_migrations, wp_yoast_primary_term

    • If the relevant database tables exist on your site database, can you please reset the indexables tables and migrations by using the Yoast Test Helper plugin?

      Once you install and activate the relevant plugin, please go to the Tools → Yoast Test → Yoast SEO → Reset indexables tables & migrations options to reset it.

    • If you are familiar with WP-CLI, you can also try running the indexables analysis by using the WP-CLI commands to see whether this works for you.
    • We look forward to hearing from you.

    @mazedulislamkhan
    I do all of this tables existed and if i remove the and reinstalled the plugin ,it created again .
    it seams like some functions not working well .
    * hosting company : Hostgator .

    Hi @mazedulislamkhan I have the same problem with 14.0.4. However, I seem to be missing wp_yoast_indexable_hierarchy and wp_yoast_primary_term. I use Digital Ocean as a host. I tried running the Yoast Test Helper but still have the problem.

    @mazedulislamkhan I solved it

    I have to check if values in config file is correct as below

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8‘);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ‘utf8mb4_unicode_ci‘);

    • This reply was modified 1 year, 7 months ago by l7azat.

    Okay so I’m new to the coding world and I’m still finding my way around it. I have my own VPS and I’ve tried all the possible methods mentioned and some even has worked for few people. I’m still not able to get Yoast SEO working.

    Here are my observations of what’s happening and if can help someone figure out how I can fix it.

    1. I uninstalled Yoast SEO
    2. I deleted existing Tables via phpMyAdmin for yoast. (It doesn’t get removed when you uninstall it from wp-admin.)
    3. I deactivate the Yoast Test Helper plugin as well.
    4. I refresh phpMyAdmin and see that I don’t have the yoast entires.
    5. I install Yoast SEO plugin.
    6. I refresh phpMyAdmin and I don’t see any yoast entires yet.
    7. I activate Yoast SEO plugin and I after I refresh phpMyAdmin I can see yoast entries.
    8. I re activate the Yoast Test Helper plugin and run the “Reset Indexable tables & Migrations”.

    I’m still getting the same error. What am I missing here?

    I have also tried editing wp-config.php with
    ———————————————-
    ** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8‘);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ‘utf8mb4_unicode_ci‘);
    ———————————————-

    I have also tried changing collation for “wp_yoast_indexable” to ‘utf8mb4_unicode_ci’ in phpMyAdmin.

    ———————————————-
    ———————————————-
    EDIT:
    I found my fix. Since I have root access to my VPS I accessed my phpMyAdmin (root). And executed following steps.

    Open phpMyAdmin (root) -> at Server: localhost
    -> User Accounts Tab
    -> Edit Privileges of ‘Whatever_Username’
    -> Check all available options and save
    -> Run the Reset Indexable tables & Migrations” in Yoast Test Helper Plugin and refresh the page
    -> Run the Yoast SEO Setup and you should be good to go.
    -> reset the Privileges for ‘Whatever_Username’ in phpMyAdmin to original and you should be good to go.

    Hope this helps.

    • This reply was modified 1 year, 7 months ago by Rikshi Kotian. Reason: Found a fix!
    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    @l7azat @rikshitpkotian Thanks to both of you for sharing the relevant fix with us. This will surely help others to fix the issue.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    This thread has been marked as resolved due to a lack of activity. You’re always welcome to re-open this topic.

    Thanks for understanding!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘14.0.4 – database error’ is closed to new replies.