WordPress.org

Support

Support » Themes and Templates » 1.3.9 has a PHP syntax error

1.3.9 has a PHP syntax error

  • Hi,

    I was trying to install 1.3.9 (using WordShell), but it appears to have a syntax error (PHP 5.3.3):

    # wordshell updraftplus pagelines --theme --showchanges --confirm --latest
    updraftplus : PageLines                   Installed: 1.3.6 (unmodified)
    PHP Parse error:  syntax error, unexpected '(', expecting '{' in ./pagelines/includes/class.actions.php on line 14
    Parse error: syntax error, unexpected '(', expecting '{' in ./pagelines/includes/class.actions.php on line 14
    ./pagelines/includes/class.actions.php: This file in the entity you have chosen to upload is apparently invalid PHP. The PHP syntax check returned: Errors parsing ./pagelines/includes/class.actions.php.
    Are you sure you wish to continue (press c to continue, any other key to abort) ? a
    ABORT: ERROR: User chose to abort

    David

Viewing 3 replies - 1 through 3 (of 3 total)
  • 1.4 has since been released, have you managed to install this update without the error?

    No, the error is still in 1.4.0:

    $ wget -q http://wordpress.org/extend/themes/download/pagelines.1.4.0.zip
    $ unzip -q pagelines.1.4.0.zip
    $ php -l pagelines/includes/class.actions.php
    PHP Parse error:  syntax error, unexpected '(', expecting '{' in pagelines/includes/class.actions.php on line 14
    
    Parse error: syntax error, unexpected '(', expecting '{' in pagelines/includes/class.actions.php on line 14
    
    Errors parsing pagelines/includes/class.actions.php
    [david@carey pagelines]$ head -14 pagelines/includes/class.actions.php|tail -1
    class PageLinesActions(){

    class PageLinesActions(){ is invalid PHP in any version.

    Hi there, thanks for coming back to us. I will bring the above to the developers attention.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘1.3.9 has a PHP syntax error’ is closed to new replies.