Support » Requests and Feedback » 1.3 way slower than 1.2 ?

  • I’ve just upgraded from 1.2 to 1.3, and there is a noticeable slow down in things. My index.php contains roughly 100 queries (lots of stuff), and the page :
    – used to render in 0.5 seconds with WP 1.2
    – renders now in 1.5 seconds with 1.3 alpha 5
    (steady benchmarks, it’s almost millisecond acurate)
    Any clue why it slowed down ? Anything not that compulsory that can be turned off in the engine ?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Ryan Boren

    (@ryan)

    WordPress Dev

    This plugin will collect each query made and the time each query takes to run and dump the information at the bottom of your page. You can see if anything is taking exceptionally long.

    I get empty pre tags, but haven’t looked at the plugin to see what’s up (just a heads up :).

    Moderator Ryan Boren

    (@ryan)

    WordPress Dev

    Oops. I forgot to mention that you must add the following line to wp-config.php.
    define('SAVEQUERIES', true);
    This cannot be defined in the plugin because plugins don’t load early enough for SAVEQUERIES to be useful.

    I added this so others visiting my site will not see the output when the plugin is activated:
    get_currentuserinfo();
    if ($user_level>9) {
    add_action(‘wp_footer’, ‘tq_dump_queries’);
    }
    ?>

    Is there any way to make this work for 1.2.1? I’m trying to figure out why my page takes so long to load without statiscized in place.

    Try just putting the function at the bottom of your index page and running it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘1.3 way slower than 1.2 ?’ is closed to new replies.