Support » Fixing WordPress » 1.2 Beta errors

Viewing 15 replies - 1 through 15 (of 22 total)
  • Sushubh

    (@sushubh)

    options does not save on one of my blogs. 🙁

    Anonymous

    On the post.php page I’m getting this error:

    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘ORDER BY meta_key,meta_id’ at line 4]
    SELECT meta_key, meta_value, meta_id, post_id FROM wp_postmeta WHERE post_id = ORDER BY meta_key,meta_id

    Anonymous

    WHERE post_id = … ORDER BY
    … no post_id?

    lamb

    (@lamb)

    any one solved this?

    Anonymous

    i get an error on 1.2 beta when i press the back button in the browser coming from the rss 2.0 feed as displayed in the browser – for the entire site.
    mod_rewrite is enabled and using the back button from the rss feed link from the archives menu, for example, is fine.
    it appears to try to go back to http://www.example.com/index.php instead of just http://www.example.com when pressing back and causes what looks like a strange apache error followed by a bunch of whacky characters. (from the rss link found on the homepage http://www.example.com/)
    any ideas?
    also i have the date problem in RSS too – and i ran both of those scripts listed in the Wiki … still i get a very strange pubdate – something from 1969. both scripts ran successfully, and at least said “done”

    Anonymous

    My default post category has also been changed upon running the update.

    Citizen

    (@citizen)

    I can’t goto the “uploads” section in the admin. Says the wp-content file isn’t set correctly permission wise, but it is.

    Anonymous

    Not sure what the deal on this is but when I click publish it just hangs … I don’t believe it is a server issue because when i pull the blog up in a seperate window the post is actually on the page, but it still is hanging in the other window.
    Just an FYI in case it is an error with others.

    Alex King

    (@alexkingorg)

    Are you pinging any sites?

    Anonymous

    yes but i was before with 1.02 and didnt have similar problems.

    annabloom

    (@annabloom)

    i get the same error as atmasphere
    Fatal error: Call to a member function on a non-object in /usr/www/users/jgreene/wp/wp-includes/class-xmlrpc.php on line 760
    when posting or editing (nightly build 29-04). all the edits are saved though despite the error. strangely enough it only happens with 1 blog, not with the other.
    both blogs are pinging

    http://rpc.weblogs.com/RPC2
    http://rpc.technorati.com/rpc/ping
    http://ping.blo.gs/
    http://rpc.blogrolling.com/pinger/
    http://ping.rootblog.com/rpc.php
    http://api.my.yahoo.com/RPC2

    additionally the blog with the error does not display edit/delete option for the default links (no tickbox either).

    Anonymous

    Definitely strange … no new nightly for 5/1 yet so I guess we just wait it out for now.

    annabloom

    (@annabloom)

    it only seems to happen with edit.php.
    i just posted something and it was fine.

    harpshot

    (@harpshot)

    I posted about this in a different thread, but probably should have posted it here:
    In admin-functions.php (file date 4/30/04 9:37 p.m.)
    Line 211:
    WHERE post_id = $postid
    maybe should be
    WHERE post_id = ‘$postid’
    I was getting the same SQL error warning that’s mentioned in the first few posts in this thread. This fix made it go away, but I don’t know if it’s a correct fix.

    Citizen

    (@citizen)

    When a nightly comes out, do we just upgrade our current versions? If so, how so?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘1.2 Beta errors’ is closed to new replies.