Support » Plugin: Elementor Page Builder » pre>$’/pre>

  • Hello,
    I’m new to elementor and wordpress, so I hope this question is not too dumb. When I create text filed with elementor and I put this sting:

    <pre>$'</pre>
    it always get canceled. It doesn’t happen with the wordpress editor.

    I tried with another installation and it still happens. Is it a problem with my installations? Is there a workaround?

    Thanks

    • This topic was modified 1 year, 7 months ago by Mattia.
    • This topic was modified 1 year, 7 months ago by Mattia.
    • This topic was modified 1 year, 7 months ago by Mattia.
    • This topic was modified 1 year, 7 months ago by Mattia.
    • This topic was modified 1 year, 7 months ago by Mattia.
Viewing 10 replies - 1 through 10 (of 10 total)
  • If you want to add code to a page, you need to add a plugin that allow shortcodes or snipets. You can add HTML code by adding that option from the choices on the left column after you have added a column. Once you go to Elementor editor, don’t go back to WP editor, they are not friendly with each other.

    • This reply was modified 1 year, 7 months ago by LesTexas60.

    You can just drop in a text editor widget and hit text on right instead of visual. Drop in the code you need update and your done. I use this method to embed PDF’s and office docs all the time.

    Ok, after further investigation, the problem is not the pre tag but only these 2 characters.
    $’

    I guess this is some kind of special sequence for elementor, but since I can’t find any confirmation online, here I am.
    I just want to add this line in a text element:
    $’

    but they keep disappearing if I exit and re-enter the editor. Since it’s something pretty basic, I guess there’s a simple solution. I don’t think I need a plugin for this. I don’t want to switch to the WP editor.
    Apologies if it’s a stupid question.

    That is a PHP Variable that holds the array of a shortcode that is why it can not be inserted.

    Ambyomoron

    (@josiah-s-carberry)

    Curious, I tried to reproduce your problem using ELementor 2.1.7
    While I cannot reproduce your issue, I do notice a different issue, which may or may not be related.
    First of all, in your two postings you are showing two different character strings. They are $' and $’
    You need to clarify which one is creating the problem.
    Secondly, what I see is that both characters are being shown as ’ when the page is viewed , or previewed, in a browser. This change by Elementor is not welcome.
    Finally, I have done the test in a Text Editor widget. I presume this is what you have done, too, but you might clarify it.

    I made a video to explain it better:

    The characthers are $(dollar) and ‘(single-quote).

    Thanks for the support

    Ambyomoron

    (@josiah-s-carberry)

    I can reproduce exactly that problem.
    I wondered if it had to do with selecting the style tab. Maybe. But I also tried the following:
    1. create a page and enter the data as above, but do not select any other tabs
    2. save as a draft
    3. close the page
    4. re-open the page in Elementor
    The $’ appears in the right panel, but not in the left panel.
    5. Click on the left panel where the $’ ought to be.
    The $’ disappears from the right panel.

    The other issue I mentioned above about changing the apostrophe character seems to be a separate issue.

    Ok I am gonna stab at this one last time. Are you using a custom font? if so change to Arial and see if issue goes away if it does then you have a font issue.

    No, I’m not using a custom font. I tried to force Arial but no changes.
    I’m using a child theme of 2017 and custom css: disabled both, same problem.

    What do you mean with this:
    “That is a PHP Variable that holds the array of a shortcode that is why it can not be inserted.”

    <pre> $ </pre> is a way a whole lot of plug ins insert short codes. The <pre>pulls in whatever that short code called `$’ is supposed to do.
    $ is the designation for a php variable and is the variable name you gave it.

    • This reply was modified 1 year, 7 months ago by Steve Stern.
    • This reply was modified 1 year, 7 months ago by Steve Stern.
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘pre>$’/pre>’ is closed to new replies.