Support » Installing WordPress » 1.0.2 to 1.2 login problems after install

  • After installing 1.2 (and keeping my old index.php file) I tried to login under admin and it will not let me. It keeps going back to the login screen and resetting my password with the lost your password function didn’t help and deleting my cookies did squat as well.
    Any ideas on what may be wrong? Also, can I switch back to 1.0.2 by just uploading my backed-up files or does the upgrade.php file change the DB so it will no longer function?

Viewing 7 replies - 1 through 7 (of 7 total)
  • I had the same thing happen to me. As long as you backed up your entire file structure (excepting the database) you can go back (or at least I could).
    What I ended up having to do was… leave the database ALONE. Delete everything from your current wp directories EXCEPT the wpconfig file. Upload EVERYTHING from 1.2. Then use the password reset and you should be able to log in. I did *NOT* have to run the wp-install.php or upgrade.php files in order to get 1.2 to work.
    The index.php for 1.02 is not the same as the one for 1.2. The 1.02 only will display a blank page, from what I could tell.

    I had this problem too, but I was able to get it working on two blogs with info I gleaned from the IRC channel. I had to create a new password hash and manually insert it into the database. Hope this helps someone.

    I had this problem the other day, and this thread helped me out.
    Here are the steps on how u can fix the problem:
    1) Go here:
    2) Enter a new password, and run the hash generator
    3) Copy the new hash
    4) Go into phpmyadmin into your wp_users table
    5) Update the password with the new hash
    6) Save, and then try to log in

    – Daynah
    Wow, thaanks alot that fixed it up!
    That hasher tool is useful, I am bookmarking that page for sure!

    The password gets sent to me, but I keep having to login….I’ve tried messing with my DB and whatever the bug is, it’s a doozy.

    I’m having the same problem, except my install was working just fine until I upgraded to the newest version. Now I can’t log in at all. I followed the instructions on the other threads and used PHPmyAdmin to delete the old pass and create a new hash for a new one, to no avail.
    Deleted the wp tables in mySQL, recreated them, and reinstalled. Installation went smoothly.
    Now I can’t log in with the admin password I was given.

    I’m having the same problem. I’ve tried everything and nothing I do lets me back in. Am I just totally screwed? 🙁

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘1.0.2 to 1.2 login problems after install’ is closed to new replies.