Support » Plugin: PayPal for WooCommerce » 10002 – You do not have permissions to make this API call

Viewing 13 replies - 1 through 13 (of 13 total)
  • Are you getting that with Express Checkout or Payments Pro?

    Plugin Contributor angelleye

    (@angelleye)

    You need to make sure the account is a business account, first of all.

    Then I need to know if this is happening with Express Checkout or Payments Pro..??

    how we can convert the account to business account

    Plugin Contributor angelleye

    (@angelleye)

    When you login to your account and click into the profile you should see a link to upgrade the account to business, unless it’s already a business account.

    I came here as the same thing happened to me. I went back to the plugin settings page to make sure I’d set it all up properly and realised I hadn’t put the ‘Live API Credentials’ in, I’d ‘skimmed’ over these settings 😉 I’ve now entered mine (obtained using the link provided on the settings page) and it works 😉

    If you’ve not done so already, look for this:

    “Get your live account API credentials from your PayPal account profile under the API Access section or by using this tool.”

    Hope that solves it.

    Plugin Contributor angelleye

    (@angelleye)

    @gemma Wild, thanks for the feedback!

    I have the same Problem with PayPal Express. When i set the API to the Live API Credential i have the error 10002 – You do not have permissions to make this API call.

    When i set it to API Sandbox i have Error 10002 Security Header is not valid.

    In the normal Woocommerce PayPal the Api and Sandbox works fine.

    Another Problem is, when i want to pay a product with PayPal Express, after click the PayPal Express Button, i have a redirect to the Product and not to PayPal.

    I use Avada Theme.

    Hope you can help.

    Thanks.

    Plugin Contributor angelleye

    (@angelleye)

    @lonewolf70, it sounds like you have a problem with the credentials configured in your system. You need to make sure the values are correct, and also make sure you aren’t sending live credentials to the sandbox or vice-versa.

    As for the button redirecting incorrectly, this could be the result of a conflicting plugin. We would need to try disabling other plugins to see if the problem goes away, and then re-enable until it comes back so we can find the culprit.

    Thanks for your fast answer.

    1. The Errors with the API is done. The Problem was at PayPal.
    2. The Error with the redirect on an single product ist done too. It was a conflict with my WP Rocket Cache Plugin.

    Now i have another question. Can i set the PayPal Button after or under the Add to cart button in single Product Pages? In your Documentation the PayPal Button ist after Add to Cart. On my site paypal is before.

    Example: https://www.reitsport-schill.com/shop/pikeur-sweatjacke-anne/

    Thanks for your support.

    Plugin Contributor angelleye

    (@angelleye)

    Your theme is adding a float: left rule on the button elements, so that’s why it’s showing up to the left of your regular button. You’ll need to adjust that through your child theme.

    Thanks a lot!

    Great Plugin!

    Plugin Contributor angelleye

    (@angelleye)

    Happy to help! If you have a moment to leave a review for the plugin that would be greatly appreciated. Thanks!

    Just for anyone landing here in the future:

    I had the same problem today (everything worked fine yesterday). It turned out that even though I didn’t run any Woocommerce updates (or any updates), my PayPal Pro API credentials disappeared out of the Checkout settings in my Woo dashboard area. I just went to my payment options, selected the credit cards via paypal pro, and went in to re-insert the API Username, Password, and Signature (found under “NVP/SOAP API integration” classic integration in the API Access portion of my business profile in PayPal).

    I hope this helps.

    • This reply was modified 2 years, 6 months ago by  TR060102.
Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘10002 – You do not have permissions to make this API call’ is closed to new replies.