Support » Plugin: WordPress Download Manager » 10 Warnings found by PHP 7.1 compatibility test

  • Resolved derekakelly

    (@derekakelly)


    Hello,

    While testing my website’s PHP 7.1 compatibility, I got the following results in regards to your plugin.

    FILE: /home/XXXXXX/public_html/wp-content/plugins/download-manager/libs/class.Crypt.php
    ——————————————————————————————————————————–
    FOUND 0 ERRORS AND 10 WARNINGS AFFECTING 5 LINES
    ——————————————————————————————————————————–
    21 | WARNING | Function mcrypt_get_iv_size() is deprecated since PHP 7.1; use OpenSSL instead
    21 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    23 | WARNING | Function mcrypt_create_iv() is deprecated since PHP 7.1; use OpenSSL instead
    23 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    25 | WARNING | Function mcrypt_encrypt() is deprecated since PHP 7.1; use OpenSSL instead
    25 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    45 | WARNING | Function mcrypt_get_iv_size() is deprecated since PHP 7.1; use OpenSSL instead
    45 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    55 | WARNING | Function mcrypt_decrypt() is deprecated since PHP 7.1; use OpenSSL instead
    55 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    ——————————————————————————————————————————–

    I hope this information is helpful to you and this warning will go away in a future version.
    Thanks,
    Derek

Viewing 1 replies (of 1 total)
  • Plugin Contributor W3 Eden, Inc.

    (@w3eden)

    Hi,
    Thanks for pointing the issues, yes, we are working on this and will be fixed with the next update.

Viewing 1 replies (of 1 total)
  • The topic ‘10 Warnings found by PHP 7.1 compatibility test’ is closed to new replies.