Support » Plugin: mb.YTPlayer for background videos » 1.0 Not working

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author pupunzi

    (@pupunzi)

    You have a javascript error on your page:
    TypeError: 'undefined' is not an object (evaluating 'tempfga.replace')
    And this is not from the mb.YTPlayer.

    That could be the reason you can’t load the video…

    Anyway you can download the previous version if you think it doesn’t work on your WP:

    http://wordpress.org/extend/plugins/wpmbytplayer/developers/

    olajideolaolorun

    (@olajideolaolorun)

    Ok i fixed that…
    The video doesnt start or load. just stays there. Please check again.

    Plugin Author pupunzi

    (@pupunzi)

    You still have errors.
    I think that it happens because you are including both prototype.js and jquery.js libraries in your page. This is causing a javascript conflict.

    Did you try using the previous version of mb.YTPlayer (6.8)?
    Does it happens with tat? if yes what are the plugins you installed before that happened?

    Bye

    olajideolaolorun

    (@olajideolaolorun)

    But they are done by wordpress. The prototype and jquery.js are both wordpress includes. Or is there a way to turn one off?

    I reverted to 0.6.8 and it works just fine. No errors on the error console either. so its all from the plugin. At first i thought it was http://wordpress.org/support/topic/broke-my-sitedowngrade But i disabled that.

    olajideolaolorun

    (@olajideolaolorun)

    Do you have a site where 1.1 actually works?

    grahamrock

    (@grahamrock)

    might want to try checking your youtube links…

    once i upgraded, i noticed my videos stopped working. then, i changed all the links from the short “share” link that youtube provides (ex: http://youtu.be/A9_MpNwduAA )to the longer youtube link ( for example: http://www.youtube.com/watch?v=A9_MpNwduAA ).

    once i did that, all of my videos work with the current upgrade.

    As Grahamrock wrote, changing the link from short to longer saved my day, too!!! 🙂

    olajideolaolorun

    (@olajideolaolorun)

    It is.

    [mbYTPlayer url="http://www.youtube.com/watch?v=BUULBlDcju4" opacity="1" ratio="16/9" quality="hd720" showcontrols="true" printurl="false" mute="false" loop="false" addraster="false"]

    olajideolaolorun

    (@olajideolaolorun)

    Just upgraded again, same thing, but the older one work.

    olajideolaolorun

    (@olajideolaolorun)

    This is the error i get now.. but i dont know where it comes from. Its only there when the new player is installed. 1.1. Not there when its 0.6.8

    Timestamp: 11/13/12 8:37:27 PM
    Error: TypeError: second argument to Function.prototype.apply must be an array
    Source File: http://s.ytimg.com/yts/jsbin/www-embed_core_module-vflZkW0CI.js
    Line: 250
    Plugin Author pupunzi

    (@pupunzi)

    Looking around the web for a similar error I found this tread where they says that mootools redefine the original javascript prototype.apply method breaking all other calls to this method:

    https://groups.google.com/forum/?fromgroups=#!topic/youtube-api-gdata/cQwzM3fknDQ

    So you should try removing the plugin that is using mootools and verify if the YTPlayer works.

    If that is true mootools is really a fake as it redefine original javascript functions. better not to use it!

    Bye,
    M

    olajideolaolorun

    (@olajideolaolorun)

    I really dont know or think i have a plugin that uses mootools.

    olajideolaolorun

    (@olajideolaolorun)

    Nope, no mootools here.

    Plugin Author pupunzi

    (@pupunzi)

    Here is another from YT API issue tracking where they have the same problem with Scriptaculos and Prototype.js:

    http://code.google.com/p/gdata-issues/issues/detail?id=3016&q=Function.prototype.apply&colspec=API%20ID%20Type%20Status%20Priority%20Stars%20Summary

    I suspect that some other library might have modified the APPLY prototype function. I have seen the same problem on 2 different sites and they always used Scriptaculous and Prototype Javascript libraries.

    chanmedia247

    (@chanmedia247)

    Hi Pupunzi, 1.1 is not working for me in IE 7, 8 , or 9. It works in chrome and firefox. Is there anything I can do to have it work in Internet Explorer? I like and notice a major difference in the delivery speed in 1.1 and would like to continue using it instead of reverting to a earlier version.

    Please Advise

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘1.0 Not working’ is closed to new replies.