WordPress.org

Forums

WP Tiles
[resolved] 1.0 beta byline template opengraph meta not working (4 posts)

  1. bradman334
    Member
    Posted 9 months ago #

    I tried to configure my byline template to use the meta property "og:description" but it did not display.

    I tried adding

    %meta:og:description
    and
    %meta:"og:description"

    It would be great to be able to use this rather than an excerpt.

    https://wordpress.org/plugins/wp-tiles/

  2. Mike Martel
    Member
    Plugin Author

    Posted 9 months ago #

    Hi again,

    The key needs to be closed off with another percentage sign, so make it %meta:og:description%.

    To be sure: is this the actual name of the custom field in WordPress? Check the 'Custom Fields' metabox (hidden by default, enable it in Screen Options) to check if you are not sure.

    Let me know if you run into any problems!

    Cheers,
    Mike

  3. bradman334
    Member
    Posted 9 months ago #

    Hi Mike,

    Thanks for the quick response.

    That was actually typo in both cases, I did have a closing %.

    Seems I misunderstood what should be used for value. I was trying to use the name of the property as it appears in html. I will have to look around the SEO plugin to see what the custom field name is, hopefully then it will work.

    I have had a number of other issues too. Should I just keep raising new topics for each?

    One such issue that is a real show stopper for me is that no matter what grid I specify it is always using the Simple grid. For example I tried including:

    [wp-tiles ... grid="..."]
    and
    [wp-tiles ... grids="..."]

    but it just continues to use the Simple grid. I can change the Simple grid template and the changes are reflected.

  4. Mike Martel
    Member
    Plugin Author

    Posted 9 months ago #

    Hi again!

    Thanks for the feedback.
    I did see that the shortcode generator was outputting grid instead of grids, which was due to some intermediary syntax - this is fixed now in the GitHub branch. The parameter to use is grids. (grid is used to pass an entire template manually)

    I haven't experienced only one grid being enabled and am not sure of how this would happen. grids takes a comma-separated list of either grid post IDs or titles (NB: not the slugs). Can you double check that you are using the titles? Also, try seeing if the grid post IDs do work. If all else fails, try setting grids to all, so the template selector will appear.

    Please post the full shortcode that you're using here, so I can trace what's happening exactly to try and figure out why this happens.

    Lastly, if you have more feedback, please post it!! I think the better place is in GitHub issues, so as not to clutter the support forum here. But also feel free to add further feedback as comments here.

    Mike

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.