Support » Plugin: Gutenberg » 10.5.2 causes some sites to break

  • After updating to 10.5.2 at least two sites I manage went down… One site simply showed a blank page except for this message: No Matching Template Found (here’s a screenshot: https://share.getcloudapp.com/jkuLR6ZZ).

    A second site was a totally blank page. Disabling the standalone Gutenberg plugin restored both sites

Viewing 15 replies - 1 through 15 (of 16 total)
  • humblynomadic

    (@humblynomadic)

    It breaks my site too (Argent theme). It truncates the homepage to an excerpt with a broken “Read more” link. Disabling Gutenberg fixed it. Was fine before last Gutenberg update.

    wwadmin

    (@wwadmin)

    I have the same issue as humblynomadic. I went back to gutenberg version 10.4.1.

    martinvdm

    (@martinvdm)

    I have the same problem. The problem is also present in version 10.5.0. I had to step back to version 10.4.1. I blank page appears with the title and a read more link. I have the problem on all pages with a media and text Gutenberg block type.

    threadnoodle

    (@threadnoodle)

    Same here. My website page content and images were not displaying. Content was restored when I deactivated Gutenberg. My images in media library are shot though, lots are still missing.

    Same problem. 10.5.0 10.5.2 and 10.5.3 break some sites.
    I’ve just few parts of the page that has been displayed. HTML seems broken.

    I’ve unactivated all the plugins. No change

    But it works on twentytwentyone… and also locally with my theme….

    So I think that some theme functions does not work with Gutenberg 10.5

    reversed to 10.4.1 and investigating …

    Found the problem.

    For some pages (don’t know why) WordPress + gutenberg 10.5 uses index.php intead of dedicated template page.

    My template is a for of understrap

    Seems strange. Anybody else encounter the problem ?

    And finally found a workaround (at least for me)

    You should have this issue if you use a specific page template. If you use default template, it works. So you can change temporarly your page template to default one.

    Issue created : https://github.com/WordPress/gutenberg/issues/31399

    Hi!
    I tried reproducing it with Argent.
    I see that the wrong template is used (index.php instead of the selected template file), but I don’t see the No Matching Template Found message. Maybe these are separate issues.

    Thread Starter Bryan Hoffman

    (@spigot)

    Here’s a bit of followup… 10.5.3 does not fix this issue. During development I use a plugin to show what templates are getting called. Gutenberg seems to be overriding the theme and calling a templated called template-canvas.php (plugins/gutenberg/lib/template-canvas.php)

    Screenshot: https://share.getcloudapp.com/8LublDbB

    @spigot do you have any html files in the theme? If so, what folder are they placed in and what are the file names? (I assume you were not trying to work with a “full site editing” theme.)

    Gutenberg checks for HTML files to try to identify if the theme has support for full site editing or not.

    Try remove_theme_supports( 'block-templates' );
    https://developer.wordpress.org/block-editor/how-to-guides/themes/block-theme-overview/#classic-themes

    That is, remove_theme_support( 'block-templates' ); without the extra s

    Thread Starter Bryan Hoffman

    (@spigot)

    @poena Thank you for the remove_theme_support() function, it did indeed fix this issue for me. I’m not using a ‘full site editing’ theme, but rather a custom theme based off of Justin Tadlock’s (@greenshady) work, Hybrid Core. There are no HTML files included, but the Hybrid Core framework does the differ from most themes in file structure.

    Thank you again,
    ~ Bryan

    The latest Gutenberg automatically adds block-templates support regardless of theme. Then, it overwrites the template hierarchy because this support is active, which breaks some themes with custom hierarchies.

    @spigot – This is happening with HC. I haven’t located the specific filter(s) yet because I’ve been away for a few days. I’m going to dig into it as soon as I can.

    Version 10.5.4 fixed this for me, @spigot.

    It has a couple of template-loading fixes: https://github.com/WordPress/gutenberg/releases/tag/v10.5.4

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.