WordPress.org

Support

Support » How-To and Troubleshooting » 1 site, 3 blogs, RewriteEngine permalinks dont works!

1 site, 3 blogs, RewriteEngine permalinks dont works!

  • andreaibz

    @andreaibz

    Hi everybody!

    (sorry for my bad english, i am from spain)

    The problem is that i have 3 installations or wordpress (3 different blogs in 3 different folders) in a website, and when i change the permalinks structure from “.. /?page_id=..” to “2008/11/11/word1-word2”, only 1 of the blogs works well with the new permalink structure pages.

    i put in the .htacces file this:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog1/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog1/index.php [L]
    </IfModule>

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog2/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog2/index.php [L]
    </IfModule>

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog3/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog3/index.php [L]
    </IfModule>

    Is correct put this code in .htacces 1 time for every blog?

    Please, there is a way for correct this? I am not expert and dont know much english, (sorry)

    Thanks a lot!

Viewing 1 replies (of 1 total)
  • iridiax

    @iridiax

    Is correct put this code in .htacces 1 time for every blog?

    No, it is not correct. Remove the root .htaccess and instead put an .htaccess in each WordPress directory containing only the code for that particular WordPress (not for all 3 of them).

    See: Using “Pretty” permalinks

Viewing 1 replies (of 1 total)
  • The topic ‘1 site, 3 blogs, RewriteEngine permalinks dont works!’ is closed to new replies.
Skip to toolbar