Support » Plugin: ATUM Inventory Management for WooCommerce » 1) Plugin kills Product Data form! 2) Settings can not be saved!

  • Resolved Indell

    (@indell)


    1) After activating the plugin, the Product Data form in the Edit Product shows only the tabs, but no content!

    2) Went to the settings page and tried changing things there, but when clicking the Update Settings button, I get the browser warning:

    [Do you want to leave this page without saving?]

    I’m using the latest version of WP and Woo, running on php 7

    • This topic was modified 1 year, 9 months ago by Indell.

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Stock Management Labs

    (@stockmanagementlabs)

    Hi Indell,

    Do you still need our help.

    We have not had any ticket opened in the official support page.

    Hope to hear from you soon.

    Pavel

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @stockmanagementlabs I’ve deleted your offer to login to your user’s site. I’m am 100% sure you mean well but please never ask for credentials on these forums.

    https://wordpress.org/support/guidelines/#the-bad-stuff

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    If something was to go wrong, then you the author may well legally become liable for damages, which they would not normally have been as their software is provided without warranty.

    Please be aware that repeatedly asking for credentials will result in us asking you to repeatedly stop before escalating up to the plugins team.

    Hi Indell,

    How can you fix this because I have the same problem. Latest wp, woo, atum on php 7

    Thanks in advance.

    Plugin Author Stock Management Labs

    (@stockmanagementlabs)

    Hi lfarkas,

    Thank you very much for your post.

    Please, deactivate all your plugins and keep WooCommerce only.

    After that start activating them one by one. Recommending to start with ATUM as your first activation.

    Check if it works after every activation.

    You will this way find the plugin causing the issue.

    Pavel

    Dear Pavel,

    I checked the plugins and ATUM 1.4.0.2 is incompatible with the WooCommerce Multilingual 4.2.9 plugin. When I activate the WooCommerce Multilingual plugin, the problem appears.

    You wrote whole WPML compliant. When will be fixed this bug?

    Plugin Author Stock Management Labs

    (@stockmanagementlabs)

    Hi Ifarkas,

    Thank you very much for your reply.

    I am glad you found the error. Yes, we are compatible with WPML.
    Of course it would be our priority to look over the error if caused by ATUM. However, we need to find out if the problem is related to ATUM.

    Would you be so kind to confirm the that the problem disappears when you have WooCommerce, WPML and The WCM 4.2.9 plugins activated and you deactivate ATUM?

    Hope to hear from you soon.

    Pavel

    Hi Pavel,

    Yes. The problem disappears when the WC, WPML and WCM is active and the ATUM is deactivated. The problem disappears too when WC, WPML, ATUM is active, and WCM is deactivated.

    Versions: WC – 3.3.3
    WPML – 3.9.3
    WCM – 4.2.9
    ATUM – 1.4.0.2

    Plugin Author Stock Management Labs

    (@stockmanagementlabs)

    Hi Ifarkas,

    Thank you very much.

    Our developers will research the issue and try to replicate on our staging sites.

    Please, give us some time for this to get tested.

    Once again, we apologise for any inconvenience caused.

    Best Regards,

    Pavel

    Plugin Author Stock Management Labs

    (@stockmanagementlabs)

    Hi there,

    Just a quick update.

    After checking the latest update and testing with WPML, we are not able to replicate the issue.

    This is needing more technical approach and I will ask you use the support link within the ATUM – Stock Central – Help menu. (Open Support Ticket).

    Hope that is ok.

    Pavel

    Hi Pavel,

    I could not open a support ticket. I do not use atum pro. I use only the free version.
    I do not want to register an account, because we are looking for a plugin for our problems. We have only developer instances that is not published to the internet.

    Laszlo

    Plugin Author Stock Management Labs

    (@stockmanagementlabs)

    Hi Laszlo,

    Registration is required to our ticket system unfortunately. It is to protect against spam and to better track users’ issues.

    But of course, I am not forcing anyone to do anything.

    We have a real full WPML running in two sites and not other users are reporting similar issue as yours. So we can only assume it is specific to your site.
    To be able to help we need to debug the website. This is an extra effort from us and the above was a solution.

    If you decide that you want our help, feel free to open the ticket and prepare a site copy and database that our premium support will need to debug.

    PS: If any admins read this post it may get deleted as we are not allowed to help user this way.

    Hope to hear from you soon.

    Pavel

    Hi Pavel,

    I reinstalled my developing wordpress with the used plugins. While I do not activate Multi Currency in WCML ATUM Works correctly. After I activated multi currency I got this exception on product admin page:
    Fatal error: Uncaught ArgumentCountError: Too few arguments to function Atum\Inc\Hooks::wpml_add_purchase_price_to_custom_prices(), 1 passed in …\wp-includes\class-wp-hook.php on line 288 and exactly 2 expected in …\wp-content\plugins\atum-stock-manager-for-woocommerce\classes\Inc\Hooks.php:450 Stack trace: #0 …\wp-includes\class-wp-hook.php(288): Atum\Inc\Hooks::wpml_add_purchase_price_to_custom_prices(Array) #1 …\wp-includes\plugin.php(203): WP_Hook->apply_filters(Array, Array) #2 …\wp-content\plugins\woocommerce-multilingual\inc\template-classes\multi-currency\class-wcml-custom-prices-ui.php(21): apply_filters(‘wcml_custom_pri…’, Array, ’36’) #3 …\wp-content\plugins\woocommerce-multilingual\inc\currencies\class-wcml-custom-prices.php(284): WCML_Custom_Prices_UI->__construct(Object(woocommerce_wpml), ’36’) #4 …\wp-content\plugins\woocommerce-multilingua in …\wp-content\plugins\atum-stock-manager-for-woocommerce\classes\Inc\Hooks.php on line 450

    I hope it helps to you.

    After this exception the original problem occurs.

    Plugin Author Stock Management Labs

    (@stockmanagementlabs)

    Hi there,

    Thank you very much.

    The above fatal error we have already fixed and will be released in the next ATUM update. However, in our system it was only warning.

    Please, wait for the next ATUM update as it will include any issues within the WPML compatibility we have discovered and fixed.

    Hope this helps.

    Pavel

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘1) Plugin kills Product Data form! 2) Settings can not be saved!’ is closed to new replies.