Support » Installing WordPress » 1 hosting plan, 2 domains, 2 wordpress sites.. I need help.

  • Resolved moonzombie


    I have a deluxe hosting plan with godaddy. I have read that what I’m trying to do is possible, and I’ve searched the forums and found relevant information and tried to get this working for about 3 days but I must be missing something.

    So I have 1 hosting plan, I have bought two domains, and I would like each domain to point to a different instance of wordpress. I have associated the 2nd domain with my hosting plan, it said “Domain2 is aliased to Domain1” (Not sure if that effects this or not, or what it really means to be honest.)

    Exemple: is the primary site, and is running fine. WordPress is installed into the root folder of my hosting plan.

    The new domain I purchased is When I added the domain to my hosting account, under my GoDaddy domain settings I specified it’s folder as (To keep it seperate from my files), and when I installed WordPress for this domain, typing would take me to the site. However, I want typing to take me to the site. I read the instructions in the wordpress settings section for this, but I still get a 403 error. I tried going in my godaddy settings and forwarding to but that doesn’t seem to do it either. (I have since removed the wordpress installation on Sirleif for the sake of starting over from scratch..)

    Basically, I’ve hit a wall trying to get this working on my own, so I need to reach out for some assistance from the community. I don’t know if it’s a domain setting with godaddy, or a hosting problem, or something I’m doing wrong with wordpress itself..

    I hope I have explained the situation clearly, if not let me know and I’ll do better.

    Thanks in advance, everyone!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You will need to log in admin panel click on Settings General and change urls to do not try to go on website as will give you error

    You will then log in Go Daddy account and go on domain name and need move all wordpress files and folders from wordpress folder to html folder now try and go the website.

    Reset your permalinks if used


    The “main issue” is that WordPress (among other scripts) creates and then unpacks the files and folders in a folder called wordpress, instead of, IMHO, doing like Joomla! does when you unpack the archive (ZIP file) and just extract the files and folders where they are and does not create this “unnecessary” folder! … it screws up a lot of folks! … me included! 🙂

    OK, rant over 🙂

    All that you needed to do was to use the Go Daddy (GD) Hosting Account File Manager to move the files from the /wordpress folder to your /sirleif folder 🙂

    If I understand you correctly, you deleted everything from your account? Going to start again? Did you install both WordPress instances with the GD Hosting Connections “one-click” install?

    Personally, what I would do now is manually install WP for both domains.

    1) using the GD Hosting Dashboard FTP File Manager (FM), upload the WP package ZIP to the root of your site
    2) once uploaded, select the ZIP then click the “Unarchive” icon from the toolbar; accept / as the location
    3) once this has unarchived successfully, then select the ZIP again and click the Move icon from the toolbar and select /sirleif as the destination (recreate the folder if you have also deleted this)
    4) do the same Unarchive at this location, making sure that it shows /sirleif when asked where to unarchive
    5) if you created both previous installs with the “one click” method, then the database info will need to be retrieved so that you can edit the wp-config.php file in each location

    To access that info, select Databases > MySQL from the top menu, then click on the pencil icon for each one to view the DB Details page where you fill find the values you need to enter into the wp-config.php file:

    Hostname, Database User name, Password, Host Name … jot down these values for each DB

    Go back to the FM, and for each wp-config.php file, select it and click the Edit icon from the toolbar; edit the 4 values and save and close.

    And to add your second domain, do this:

    1) log in and get to your GD Hosting Dashboard
    2) select Settings > Domain Management
    3) click “Add Domain” (upper right)
    4) at the next screen, enter the second domain (with OUT the www.) in Domain: and in Folder: enter sirleif so that the entry looks like this /sirleif
    5) click “OK” and then wait for a while (up to an hour or so) before this domain addition has a chance to take effect


    You need to point the 2nd domain ( to the subfolder on your webhost. The last part of 2ninerniner2’s instructions should help you do that.

    govpatel’s solution will overwrite

    govpatel’s solution will overwrite

    If the domian names are set right then when you log in Go daddy and click on hosting you should see the domain names and you click on domain name and will take you that domain name file manager.

    Thank you to everyone for the replies, and a huge thanks to 2ninerniner2 for taking the time to go into detail for me. Through no fault of your instructions, I am still a bit lost here so I figure the easiest thing to do would be to describe what I have done so far and possibly you can point out what I have done wrong/what I have missed?

    So the ‘html’ folder of my hosting account had nothing in it except the wordpress folders and files for, which is functioning properly so I’m just going to leave it alone.

    Now, I have done a fresh installation of wordpress for the domain in a folder called /sirleif. So now if we type in, there’s a working installation of wordpress. I went to the hosting control center, and under “Domain Management” I selected the domain and selected “/sirleif” as the folder. The status is “Setup”. I had thought doing this would make it so that typing makes the browser look for the files in /sirleif, which would essentially be like typing in, but it seems that isn’t the case as you can see the following error by typing in


    You don’t have permission to access / on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

    Looking back at my file manager after the installation, there is an empty folder called sirleif, and there is also a folder called wordpress with another sirleif folder inside it which contains all the wordpress files. I tried moving the files from wordpress/sirleif folder to the /sirleif folder, however this stopped the site from working so I moved them back.

    I’m going to just leave things as they are for now and await further instructions.

    And just to summarize, here’s how things are presently.

    The root folder on my hosting account has all the wordpress files for, and that’s all working great. There’s also an empty folder called sirleif, and there’s another folder called wordpress which contains another sirleif folder with all the wordpress files inside of it. Moving the wordpress files from wordpress/sirleif to the sirleif folder in the root directory broke the site, so I moved them back for now..

    Yikes, thanks again everyone and I apologize if I’m missing something really obvious here.

    A quick note to govpatel: note that the account in question is a deluxe hosting account and therefore ALL domain installations are hosted from one File Manager 🙂

    OK, from what you describe, you have done the correct actions. This is what you should have for these two to work:

    1) as you say, is working fine and all files and folders are in the root of the hosting account; this is how it should be as there HAS to be a PRIMARY DOMAIN for GD Hosting Accounts; this is the one and it must reside in the root … fine, leave this alone 🙂

    2) should have all it’s files and folders in a folder within the root, called sirleif (for example)

    3) the method you used to set up the domain to point to the sirleif folder is correct; HOWEVER, it should also be pointed out that doing this is NOT an immediate process!!! Even though it shows as “Setup” in the Domain Manager, it can take up to 2 to 3 hours for it to “take”; be patient 🙂

    4) you said you had a “working installation” at; if this is the case, then what you needed to do was edit the database for the Sitename and Home URL; once you get your files and folders back to where they belong, you will still need to do this:

    – from the Hosting Control Center, select Database > MySQL
    – click the “Manage via phpMySQL” link for the database for sirleif
    – login with the username and password you used to set up the database
    – when phpMyAdmin opens, in the left pane, click on the + beside the DB name to expand; then click on the wp_options table
    – in the right pane, click the “Browse” tab
    – click the pencil icon in the siteurl row (should be first item)
    – edit the value there so that it’s and then click the “Go” button, lower right
    – click the “>” button to move to the next page and find the “home” row; edit it in the same way as the above
    – click the “Exit” icon at the top of the left pane to log out of phpMyAdmin

    That should get the site working 🙂

    To review:

    1) / = root site has files and folders:

    2) /sirleif = has files and folders

    3) Domain Manager entry for is:

    Domain Name: Folder: /sirleif Status: Setup

    Hey there,
    Thanks again for all the help 🙂

    Just wanted to give an update in case anyone reading this is in the same boat as me in the future.

    What the problem was, is that I didn’t have the domain setup with the correct IP address for the hosting (Or something like that :P) But it’s all sorted out now.

    Cheers everyone!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘1 hosting plan, 2 domains, 2 wordpress sites.. I need help.’ is closed to new replies.