Support » Localhost Installs » 1 error remains in the includes after migration

  • Resolved jknetdesign


    I built a child theme of twentyeleven on MAMP.
    I migrated to a small hosting company (not cPanel).
    In the options table in the database I changed siteurl and home to
    It’s all there but I get an error in the Media section of the Dashboard.
    Warning: imagejpeg() [function.imagejpeg]: Unable to open ‘/home/benjishake/domains/×83.jpg’ for writing: Permission denied in /home/benjishake/domains/ on line 459
    Is this a permissions issue?
    I only see this error when I attempt to edit an image.

Viewing 6 replies - 1 through 6 (of 6 total)
  • That error is a read/write error, it’s simply telling you that the graphic file isn’t writable.

    If you open your site in an FTP client, change the image permissions to 755 and you should be OK.

    What folders exactly? I set wp-content and uploads to 777.I also tried this on the 2012 folder (where my images are) and it does not accept 777. It stays at 755.

    I have the same error after migration for my website. Error still there after I did changes on the image permissions to 755.

    What to do?

    GOT IT!

    The permission error is being generated because the server can’t write to the file…because it’s not where it thinks it is.

    It would have helped if I could copy and paste your text from your error page, but go into your ftp and expand the uploads folder > 2012 > 03, right click, set permissions to 777, execute all, ok (Dreamweaver). Do this for every image in each of these monthly directories. It probably currently says 644. A better way is to execute a mass file permission via shell access, but I jut did it this way since I have a manageable amount of images.

    THANK YOU VERY MUCH!! I got it now.
    I did set the file permissions to 777 and now my images can be viewed.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘1 error remains in the includes after migration’ is closed to new replies.