Support » Plugin: FooGallery Image Gallery – Responsive Photo Gallery » 1.7.4 images don’t automatically display on mobile

  • Hi,
    just updated to latest version and on mobile, the photos don’t render at all. Fine on desktop. I can click on the picture and it will display or click on the next page button and those display. Typically the little animation appears while pics are loading but this didn’t even do that.

    I was running autoptimize and cleared cache, even disabled the plugin to be sure it wasn’t that. I reverted back to previous version and it was fine. Was using android for mobile and Chrome. Can you see if you get this same problem please? Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author steveush

    (@steveush)

    Hi @iguanamom,

    Could you provide some more details please, like your type of phone and your Android and Chrome versions? Also a link to your site would help me out as I can’t reproduce the issue in testing.

    Thanks
    Steve

    OC Marie

    (@healthyuandi)

    Hi Steve,
    I think I’m in the right spot now. I am having the exact same problems
    My galleries work on my desktop but not on my android phone they were fine before the update https://potterycrafters.com/recommended-tools/
    Samsung S5
    GeneratePress Premium is my WordPress theme
    Thanks, Marie

    Plugin Author steveush

    (@steveush)

    Hi @healthyuandi,

    Could you please try clearing your browser cache on your phone. There was a change made in the latest version that if the old JavaScript is served along with the new HTML loading issues could occur. Android generally has a very aggressive caching policy and I just want to make 100% sure that this is not simply a caching problem before I begin digging deeper into the code.

    I have tested your site using a Samsung S4, S5, S8 and S9 phone and the built-in browser and your page loads as expected along with all the images.

    Thanks
    Steve

    OC Marie

    (@healthyuandi)

    Hi Steve,
    Okay, I have no idea what that is or exactly where to find it on my phone, this may take awhile I’m going to have to Google it to find out how. Or remove the plugin
    55% of my traffic is from mobile…ouch!
    Thanks for your help.
    @healthyuandi

    OC Marie

    (@healthyuandi)

    Hi Steve, I found a video that shows how to clear the cache on an android. And Foo Gallery is working perfectly.
    Thank You
    https://www.google.com/search?q=clear+android+cache&rlz=1C1CHBF_enUS772US772&oq=clear+android&aqs=chrome.0.0j69i57j0l4.13962j0j7&sourceid=chrome&ie=UTF-8#kpvalbx=1

    Thanks everyone for figuring this out. However, I will have to say that a typical user hitting this page certainly isn’t going to know to do this and will just figure it doesn’t work (that looks bad). Can I assume there’s no way to patch this so a clear cache doesn’t need to be done? I really like this plugin but I can’t take the chance that visitors coming to that page aren’t going to be able to see these photos right away.

    Thanks!

    Hi,
    noticed you did an update which I have tested in a staging environment. At first it took well over 20 seconds to load on mobile and desktop. I re-enabled autoptomize and cleared that cache. Tried again and nothing. Tried again and it loaded fine on both. Thank you for your patch and hard work on this!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘1.7.4 images don’t automatically display on mobile’ is closed to new replies.