Support » Plugin: Imagify Image Optimizer » 1.6.14 WP Customizer Error with Beaver Builder Theme

Viewing 9 replies - 1 through 9 (of 9 total)
  • pointsi

    (@pointsi)

    I also traced a major issue today to my 1.6.14 upgrade today:

    It causes all tabs (like “Visual / Text”) and drop-downs (like “Screen Options” and “Help” etc) on post edit pages to become unclickable.

    Deactivating the plugin fixes the issue.

    I thought this version was supposed to improve compatibility, but I think there may still be some fixes necessary.

    Zach Adams

    (@zach-adams)

    Likewise with the Visual Composer. Console error:

    Uncaught TypeError: (intermediate value).setHSpace is not a function

    Weirdly if I enable SCRIPT_DEBUG it starts working again.

    Edit: The Chart.js version included in Imagify update 1.6.14 is defining an object for ‘Color’ which interferes with the built-in WordPress ‘Color’ javascript library which is included with the WP colorpicker:

    https://github.com/Automattic/Color.js/blob/master/src/color.js
    https://github.com/Automattic/Iris

    Edit Edit: Here’s a quick fix you can throw in your theme’s functions.php file if you can’t wait for an update:

    function imagify_1_6_14_fix() {
        wp_deregister_script('imagify-chart');
        $assets_url = (defined('IMAGIFY_ASSETS_JS_URL')) ? IMAGIFY_ASSETS_JS_URL . 'chart.min.js' : trailingslashit(get_bloginfo('url')) . '/wp-content/plugins/imagify/assets/js/chart.min.js';
        wp_register_script('imagify-chart', $assets_url, [], '2.7.1');
    }
    add_action('admin_enqueue_scripts', 'imagify_1_6_14_fix', 100);

    It just reregisters the Imagify chart library to load after the default WP colorpicker library.
    Not sure if it works on other theme builders but it worked for Visual Composer.

    • This reply was modified 11 months ago by  Zach Adams. Reason: additional info
    • This reply was modified 11 months ago by  Zach Adams. Reason: found fix
    • This reply was modified 11 months ago by  Zach Adams. Reason: formatting
    Plugin Author WP Media

    (@wp_media)

    Hi,

    We apologize for the error you experienced with the latest version of Imagify.

    We have identified the issue and our team is already working on releasing an update to fix this issue as soon as possible.

    Once it has been fixed, we’ll keep you informed. Thank you! 🙂

    Plugin Author WP Media

    (@wp_media)

    Hi!

    Imagify 1.6.14.1 has been released.

    The conflicts between our script used for the charts and theme builders, or plugins that use an outdated version of this script are now solved.

    Kindly update to this version.

    Have a nice day! 🙂

    pointsi

    (@pointsi)

    The issues I encountered with 1.6.14 have not resolved after updating to 1.6.14.1. I’m hoping there are still additional conflicts to be fixed.

    Thanks for the prompt replies!

    Plugin Contributor ScreenfeedFr

    (@greglone)

    Hello.
    It should be fixed in 1.6.14.1. Can you try to empty your browser cache? Thanks.
    Greg

    pointsi

    (@pointsi)

    Hi Greg,

    I have cleared the cache, etc on multiple browsers, but Imagify still causes all tabs (like “Visual / Text”) and drop-downs (like “Screen Options” and “Help” etc) on post edit pages to become unclickable.

    Thanks

    Plugin Contributor ScreenfeedFr

    (@greglone)

    OK, can you contact us so I can investigate directly on your site? Thanks.

    pointsi

    (@pointsi)

    Thanks for your patience. I tried a more exhaustive emptying of browser cache/content settings/cookies etc, and then emptied WP Rocket and CloudFlare cache again too, and finally it works again 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘1.6.14 WP Customizer Error with Beaver Builder Theme’ is closed to new replies.