Support » Plugin: Redis Object Cache » 1.6+ breaks Woocommerce Zapier plugin

  • Resolved ccolotti

    (@ccolotti)


    Everything was working fine as soon as I upgraded to 1.6.1 the zapier connections to woocommerce broke with this error:

    authentication failed: Cannot read property ‘consumer_key’ of undefined

    I disable this plugin and it works fine.

    I rolled back to 1.5.9 and the zapier connection once again works fine. As soon as I upgrade past 1.5.9 it completely breaks the connection..

    I am not sure what changed in the object cache plugin that would affect the zapier connection to the woocommerce zapier plugin, but there’s a major conflict.

    • This topic was modified 1 month, 2 weeks ago by ccolotti.
    • This topic was modified 1 month, 2 weeks ago by ccolotti.
Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    I’m working on a fix, will be out with 30min 👍🏻

    @tillkruess thank you! I was going bat____ Insane chasing this down fighitng with zapier, and OM4 the woocommerce zapier vendor..

    FWIW they found this in the logs which I am sure you are aware of…

    {"code":"wc_zapier_method_not_allowed","message":"405 Method not Allowed","data":{"status":405}}
    <!-- Performance optimized by Redis Object Cache. Learn more: https://wprediscache.com -->

    That line second advertisement line is breaking it

    • This reply was modified 1 month, 2 weeks ago by ccolotti.
    • This reply was modified 1 month, 2 weeks ago by ccolotti.

    Hi Tim,

    The problem is being caused by your Redis plugin outputting the following HTML comment as part of all responses:

    <!-- Performance optimized by Redis Object Cache. Learn more: https://wprediscache.com -->

    Our JSON API endpoints then end up with that HTML output as part of our JSON responses, which breaks our endpoints.

    Is it possible for you to remove/disable that HTML output?

    Our custom endpoint sets the to true:

    define( 'REST_REQUEST', true );

    So perhaps your plugin could only output the comment if REST_REQUEST isn’t defined (or if it is false).

    James

    Plugin Author Till Krüss

    (@tillkruess)

    @ccolotti: Thanks for the details, I was able to reproduce it and just tagged v1.6.2, which should resolve the issue. If it doesn’t please let me know!

    @jamescollins I suspect that wonderful little advertisement line is breaking a lot of stuff…hopefully the fix @tillkruess is working on just removes it completely. It’s tough when a change like that breaks things so badly…I have lost 2 hours of zap automations on an ecommerce site from it, but sounds like it’s going to get resolved ASAP. Hopefully it was just an oversight not “by design” 🙂

    I don’t even want to know what else is broken on all my other sites right now…LOL

    • This reply was modified 1 month, 2 weeks ago by ccolotti.
    Plugin Author Till Krüss

    (@tillkruess)

    @jamescollins: Yes, you can disable the HTML comment using the WP_REDIS_DISABLE_COMMENT constant, or upgrade to v1.6.2 will should resolve the issue.

    Plugin Author Till Krüss

    (@tillkruess)

    @ccolotti: Yes, a dump oversight on my end. I’m terribly sorry about this.

    Great stuff @tillkruess , thanks for the quick fix.

    James

    confirmed seems to be back working….although the long disconnect dropped my zapier accounts….so some more time to recover on my end. :/

    @tillkruess let’s not do that again shall we? 🙂

    Plugin Author Till Krüss

    (@tillkruess)

    Yeah, no. Also, check your emails 🤫

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.