Support » Plugin: Wholesale Suite – WooCommerce Wholesale Prices & B2B Plugin » 1.11.5 Crashes the site with WC 3.9.1

  • Resolved dk9

    (@dk9)


    I will revert to version 1.11.4 because it simply crashed my site.

    • This topic was modified 2 years, 2 months ago by dk9.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter dk9

    (@dk9)

    Thanks, I saw that post and reverted to 1.11.4
    Cheeers

    Plugin Author Josh Kohlbach

    (@jkohlbach)

    Hey folks, we’ll have a patch out ASAP for this. Likely today.

    Typically we only test with the prior two versions of WC, their release cadence makes it hard for us to keep up otherwise (since they’re now releasing monthly).

    Regardless, apologies for the inconvenience.

    Plugin Author Josh Kohlbach

    (@jkohlbach)

    Hi @dk9 and @seldimi,

    Please update to version 1.11.6 which includes a patch for 3.9.x support.

    Apologies again for the inconvenience.

    Issue still exists with WC 4.1 and 1.1.6

    Fatal error: Uncaught Exception: Uncaught Exception: Invalid data store. in /home/www/webex5/website.com/www/wp-content/plugins/woocommerce/includes/class-wc-data-store.php:107 Stack trace: #0 /home/www/webex5/website.com/www/wp-content/plugins/woocommerce/includes/class-wc-data-store.php(139): WC_Data_Store->__construct(‘admin’) #1 /home/www/webex5/website.com/www/wp-content/plugins/woocommerce-wholesale-prices/includes/wc-admin-notes/class-wwp-install-acfw.php(95): WC_Data_Store::load(‘admin-note’) #2 /home/www/webex5/website.com/www/wp-includes/class-wp-hook.php(287): WWP_Install_ACFW->dismiss_install_acfwf_note(”) #3 /home/www/webex5/website.com/www/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array) #4 /home/www/webex5/website.com/www/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #5 /home/www/webex5/website.com/www/wp-admin/admin.php(170): do_action(‘admin_init’) #6 /home/www/webex5/website.com/www/wp-admin/index.php(10): require_once(‘/home/www in /home/www/webex5/website.com/www/wp-content/plugins/woocommerce/includes/class-wc-data-store.php on line 107

    • This reply was modified 2 years, 2 months ago by Web Expert.
    Plugin Support Fauzan Azizie

    (@fauzanade)

    Hi @seldimi,

    After further investigation, this issue happens on WooCommerce installation with WooCommerce Admin feature is disabled. From your post in another thread, it seems that you’ve disabled the WooCommerce Admin using a custom snippet. So I’d suggest you remove this snippet temporarily.

    We’ll consider this case and release a countermeasure for this in the next update.

    Plugin Support Fauzan Azizie

    (@fauzanade)

    Hi @seldimi,

    We’ve released a new update for WooCommerce Wholesale Prices 1.11.8 with the improvement for WooCommerce Admin. It’ll work fine even when you have the WooCommerce Admin inactive. You may safely update your plugin now.

    Cheers

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘1.11.5 Crashes the site with WC 3.9.1’ is closed to new replies.