Support » Plugin: Asset CleanUp: Page Speed Booster » 1.3.4.0 seems to have broke my jquery some how

  • Resolved luigsm

    (@luigsm)


    To start with I love your plugin. I found it just a little while ago and it has worked great, until I just updated from 1.3.3.9 to 1.3.4.0 . I had to de-active your plugin for right now, as it drastically changed the site.

    I had an issue on a few pages. Here are 2 of them.
    https://curedesigngroup.com/wordpress/ – issue with the slider
    https://curedesigngroup.com/wordpress/services.html – somehow broke the layout

    Could you send me a link to install the 1.3.3.9 version?

    Thanks for any assistance.
    Mike

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Gabe Livan

    (@gabelivan)

    @luigsm It could be an incompatibility with one of the plugins (if you updated them at the same time) or a path to fonts/backgrounds (note that it was mentioned on https://wordpress.org/support/topic/last-update-broke-my-font-awesome-fonts-loading/ – However, you’re saying it’s related to jQuery. I’ve noticed you deactivated the plugin as the website loads fine now. While I’m checking this, you can download 1.3.3.9 from https://wordpress.org/plugins/wp-asset-clean-up/advanced/ (scroll to Previous versions and select the version you want from the drop-down).

    PS: On a side note, I’ve noticed your CSS was having the following import:
    @import "http://fonts.googleapis.com/css?family=Century+Gothic"
    This was happening while the page visited was via HTTPS – the browser will block the request if it’s not via HTTPS as well. It should be @import "https://fonts.googleapis.com/css?family=Century+Gothic" (notice the extra ‘s’)

    You can read more about it here: https://developer.mozilla.org/en-US/docs/Web/Security/Mixed_content/How_to_fix_website_with_mixed_content

    • This reply was modified 1 month, 2 weeks ago by  Gabe Livan.

    I have found a feature you have in the setting that fixed my issue, but not sure why it broke it. Looks like it was css not the jquery

    settings – optimize css –
    Combine loaded CSS (Stylesheets) into fewer files
    I turned this off and everything is working now.

    Thanks for any information.
    Mike

    • This reply was modified 1 month, 2 weeks ago by  luigsm.

    Thanks for the @import issue. I will look at fixing that.
    Mike

    Plugin Author Gabe Livan

    (@gabelivan)

    @luigsm When combining CSS, there could be an issue with the way your CSS is created and your website is just not compatible with that. A new CSS minify feature was added in 1.3.4.0 which is overall better than the previous one. IF you take a look here https://curedesigngroup.com/wordpress/wp-content/themes/adapt/custom-style.css?1562085756 you’ll notice the following string in the beginning:
    (this messaging system doesn’t print it the same way as it’s in the file, but you can notice it’s before body{background:#000005;)
    This syntax is not valid (perhaps it was appended there by mistake) and you might want to strip it out. Other files could have the same thing. I’ll check more files from your website, perhaps I could find other issues like that.

    • This reply was modified 1 month, 2 weeks ago by  Gabe Livan.
    • This reply was modified 1 month, 2 weeks ago by  Gabe Livan.

    @gabelivan – I just made that fix. That was an interesting find. thanks. Did not fix my issue, but it makes my code better. thanks
    Mike

    @gabelivan – if you are interested I can turn the setting on to show you what is breaking. Otherwise I am going to go with the setting off.

    Please let me know if that will help you at all.

    thanks,
    Mike

    Plugin Author Gabe Livan

    (@gabelivan)

    @luigsm yes, I’m interested. Please do so! Is https://curedesigngroup.com/wordpress/ like a temporary URL? I mean like a staging environment…

    @gabelivan – no its a live production url. late night hours have much lower volume and I would love to help you make your awesome plugin better. Would a window starting at 10pm to midnight CST be good for you. I can make that happen most days.

    Thank you again for all your hard word.
    Mike

    @gabelivan – please let me know you would like a window opened coming up.

    thanks,
    Mike

    Plugin Author Gabe Livan

    (@gabelivan)

    @luigsm Yes, I’d like that! 10 PM to midnight CST would not work for me. How about the weekends from 14:00 to 15:00? Would this Sunday work for you? Usually, the traffic is considerably lower on weekends.

    @gabelivan – Sounds good. do you want me to update the code to the 1.3.4.0 or the 1.3.4.1 . Guessing the 1.3.4.1 and turn off my cdn and dump all of my cache. Is that what you are looking for? do you wnat or need anything else? Not sure if I can give you my number on here, if you need me to do anything for you right away.

    thanks,
    Mike

    @gabelivan – checking if we are doing this at 14:00 today and what you are needing.

    thanks,
    Mike

    Plugin Author Gabe Livan

    (@gabelivan)

    @luigsm I’m available starting from now for the next 2 hours. So anytime between this internal will work for me. I’d like the Combine CSS option turned ON (which caused that bug you mentioned) and upgrade to the latest version of the plugin (if you haven’t already).

    @gabelivan – making the changes now.

    thanks,
    Mike

    @gabelivan from what I can tell, I can not replicate the issues with 1.3.4.1 . It might only been happening with 1.3.4.0 . thank you for your time to look at it and work on it!!!!!!!

    I love your plugin!

    THANK YOU AGAIN!
    Mike

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.