Support » Fixing WordPress » 1.2 & .htaccess blues

  • I have WordPress 1.2, the default permalink structure, and the automatically-generated .htaccess code, (modified, but it didn’t work before either) but my mod_rewrite is not pointing to my monthly and individual archives at all.
    Update: Fixed by re-creating .htaccess.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m having the same problem. Permalink, trackback, and comment links are all broken when applying the above permalink structure and adding the above code the the .htaccess file.
    John

    Just wondering.. do you have Apache 2.0?

    I have no help to offer.. but I am having the same problem with both comments not being visible and links to monthly archives not working when I mess with the permalinks.
    It’s running on Red Hat Linux 7.2….

    I got it working by reseting the archive path and a fresh .htaccess file . Frankly, I have no idea why it wasn’t in the first place, but here is the new content of my .htaccess:
    Options +FollowSymLinks
    ErrorDocument 404 /404.html
    RewriteEngine On
    RewriteBase /
    RewriteRule ^archives/category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?category_name=$1&feed=$2&section=1 [QSA]
    RewriteRule ^archives/category/?(.*) /index.php?category_name=$1&section=1 [QSA]
    RewriteRule ^archives/author/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?author_name=$1&feed=$2&section=1 [QSA]
    RewriteRule ^archives/author/?(.*) /index.php?author_name=$1&section=1 [QSA]
    RewriteRule ^archives/([0-9]{4})?/?([0-9]{1,2})?/?([0-9]{1,2})?/?([_0-9a-z-]+)?/?([0-9]+)?/?$ /index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5&section=1 [QSA]
    RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?year=$1&monthnum=$2&day=$3&name=$4&feed=$5&section=1 [QSA]
    RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/trackback/?$ /wp-trackback.php?year=$1&monthnum=$2&day=$3&name=$4&section=1 [QSA]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /wp-feed.php?feed=$1&section=1 [QSA]
    RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /wp-feed.php?feed=$1&withcomments=1&section=1 [QSA]

    Playing around with it…
    Doing things like in one of the examples (/%year%%monthnum%/%day%/%hour%/%postname%) works just fine.
    Changing it a little to switch a slash for an underscore (/%year%%monthnum%/%day%/%hour%_%postname%) and the monthly archives quit working, but the comments are still there.
    Change it a little more to closer to what I want to do (/%year%/%monthnum%/%day%/%hour%_%minute%_%second%/) and the archives still don’t work and the comments are no longer there.
    Very strange. Unfortunately I don’t understand mod_rewrite well enough to try and fix whatever is wrong myself. I’m trying to get permalinks to be the same as I have them with MT… something like http://maybe.iotoeuropa.org/archives/2004/05/01/14_02_51.php

    Moderator Ryan Boren

    (@ryan)

    WordPress Dev

    The year/month/day archives will no longer work if you insert a static string or character in the permalink. In this case, the static characters are the underscores. You wil have to make your own rewrite rule if you want to handle this.

    I’m not using any static charcters and my ctaegory permalinks do not work.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘1.2 & .htaccess blues’ is closed to new replies.