Support » Plugin: Easy WP SMTP » 1.2.7 Triggers Fatal Error in PHP 5.2.x

  • Unfortunately, this is on GoDaddy hosting and I can’t get the client to move off of it. To be fair, WordPress does support PHP 5.2. πŸ˜‰

    Parse error: syntax error, unexpected T_FUNCTION in /***/easy-wp-smtp/easy-wp-smtp.php on line 174

    Line 174:

    $mail->Debugoutput=function($str, $level) {global $debugMSG; $debugMSG.=$str;};

    Commenting out the line above corrects the issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support mbrsolution


    Hi, PHP 5.2 is very old and not supported any more. Plus it is dangerous to run an old not support PHP version in your server. Have you considered updating your PHP version in your server?

    Unfortunately, this is on GoDaddy hosting and I can’t get the client to move off of it.

    Not my call. πŸ™‚

    Plugin Support mbrsolution


    Hi, I understand perfectly what you mean. You might like to explain to your client the importance of security just so you cover yourself. In my humble opinion. I am sure GoDaddy will accommodate updating the PHP version in the server.

    However I have submitted a message to the plugin developers to investigate further your issue.

    Kind regards

    • This reply was modified 2 years, 5 months ago by mbrsolution.
    Plugin Author wp.insider


    That PHP version is just too old. We don’t support it unfortunately. PHP5.2 has reached end of life. WordPress recommends using PHP7:

    We use more modern functions in this plugin that are just not available in such a old version of PHP. You will need to look for an alternative plugin if your client can’t upgrade PHP to a more recent version.

    That same page says WordPress supports PHP 5.2.4. Here’s a suggestion if you’re open to it…

    Since WordPress officially supports PHP 5.2.4, it doesn’t make sense that your plugin would trigger fatal errors in that environment. It’d be better if the plugin automatically deactivated or displayed a warning if the server doesn’t meet the plugin’s requirements.

    For example, something as simple as:

    // Exit gracefully if PHP version is lower than 5.3.2
    // @todo remove this when WordPress drops support for PHP version < 5.3.2
    if (version_compare(PHP_VERSION, '5.3.2', '<')) { ... }

    My two cents. πŸ™‚ I’ll leave you alone now.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘1.2.7 Triggers Fatal Error in PHP 5.2.x’ is closed to new replies.