Support » Plugin: WP Editor » 1.2.6.2 // Invalid Javascript // IE + Safari Incompatibility

  • bodyboarder20

    (@bodyboarder20)



    Plugin version 1.2.6.2 introduced JavaScript that is not valid, causing incompatibility issues in IE and Safari.

    The bug was injected in this changeset:
    https://plugins.trac.wordpress.org/browser/wp-editor/trunk/js/posts-jquery.js?rev=1438176

    The invalid javascript syntax involves the attempt to set default values for function parameters:

    window.wp_editor_qt = function( element, start = true ) {

    and

    window.get_content_cursor = function( element, pos = 'from' ) {

    and

    window.set_content_cursor = function( element, fromCursor, toCursor = {} ) {

  • The topic ‘1.2.6.2 // Invalid Javascript // IE + Safari Incompatibility’ is closed to new replies.