Support » Plugin: UpdraftPlus WordPress Backup Plugin » 1.16.26 – The plugin does not have a valid header.

  • Resolved tim_radford

    (@tim_radford)


    Hi

    This is a great plugin that has worked flawlessly, however the latest update 1.16.26 fails on on six separate sites (standalone and multi-site).

    “The plugin does not have a valid header.”

    I have tried deleting the updraftplus folder and reinstalling manually with no success. I have stopped the update on the remainder of my sites and they still work fine.

    Any suggestions welcome.

    Thanks

    Tim

Viewing 5 replies - 1 through 5 (of 5 total)
  • We’re looking into this. If you deactivate and re-activate a random other plugin (any will do) this will reset the cache and should fix it.

    Someone else reported the problem, and we thought it was a core issue, however we’re looking into solving it for you and anyone else.

    Thread Starter tim_radford

    (@tim_radford)

    Thanks for the advice. It worked OK on one site, but not others. Some errors received include:

    Installation failed: Could not copy file. updraftplus/vendor/symfony/process/ProcessBuilder.php

    Update Failed: Could not copy file. updraftplus/vendor/symfony/process/Pipes/WindowsPipes.php

    I notice that the file structure for updraftplus is unusual. You have a copy of the updraftplus folder contained within itself. Is this intentional?

    Thanks

    Tim

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi Tim,

    Apologies for the inconvenience.

    There is an issue with the current downloadable zip, where the structure is duplicated. We will update the zip as soon as possible, but my colleague with access to do so is currently out of the office.

    In the meantime, for any site where the plugin cannot install/update, please could you download a copy of the plugin from here? Then unzip and delete the extra ‘updraftplus’ directory and rezip the folder.
    You should then be able to install that copy by uploading it to the site.

    Thread Starter tim_radford

    (@tim_radford)

    Deleting the duplicate folder, re-zipping and installing via upload solves the problem on all steps.

    Thanks very much for your help.

    Tim

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Just as an update, the zip download has now been fixed.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘1.16.26 – The plugin does not have a valid header.’ is closed to new replies.