Support » Plugin: Nav Menu Roles » 1.10.0 update and hook in WP5.4 core

  • Resolved Bart Kuijper

    (@spartelfant)


    Hello,

    The 1.10.0 changelog (Fix: My hook made it into core for WP5.4!! Can finally stop overriding the admin menu Walker.) made me wonder if we should postpone updating this plugin until the release of WP 5.4 (currently scheduled for 31 March 2020). Or will this update also still work on WP 5.3.2?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author HelgaTheViking

    (@helgatheviking)

    It is compatible up to 5.4 and still back-compatible. It should check your WP version and for WP 5.3 it will keep replacing the admin menu Walker like it has always done.

    Thread Starter Bart Kuijper

    (@spartelfant)

    That makes perfect sense, I feel like I owe you an apology for even considering that you had broken backwards compatibility.

    Thank you very much for your fast answer and thank you even more for the continued development of this excellent plugin!

    Plugin Author HelgaTheViking

    (@helgatheviking)

    it wouldn’t be the first time. but usually I would do that with more intention and bigger fanfare. This update was to just make sure it starts using the core hook when it arrives…. it’s been 84 years!

    Don’t forget to leave a review.

    Thread Starter Bart Kuijper

    (@spartelfant)

    Don’t forget to leave a review.

    Done and thanks again!

    Plugin Author HelgaTheViking

    (@helgatheviking)

    Thanks Bart!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘1.10.0 update and hook in WP5.4 core’ is closed to new replies.