Support » Plugin: Gallery Custom Links » 1.0.9 corrupts gallery as reusable block in WP 5.0 and 5.1

  • Resolved olafberg

    (@olafberg)


    Hi,

    I ran yesterday into an issue with an gallery marked as “reusable block”. When I want to edit a page where that gallery is used, the block appears as a gray block with the letters “block has been deleted or is not aviable” (translated from German). When I select from the “tool menue” on the upper right side the point “manage all reusable blocks” the block appears in the list. I can view and edit the block but get an error when saving the changes: “saving failed”.

    Before I ran into the problem I did an update from WP 5.0 to WP 5.1 and an update of the Gallery Custom Links Plugin to 1.0.9. So first I thought it might be trouble with WP 5.1. and the database update during the update process. But today I reversed to WP 5.0 and restored the database to the state before the update while keeping the Plug-In update to 1.0.9. and the issue still exists. When I deselect the Plug-In I can view and edit the reusable gallery block. When I activate the Plug-In I get the issues mentioned abouve.

    I use WP 5.0.3 (or 5.1 respectivly, see above) and the Ribosome Theme. I also tried the “Twenty Nineteen” Theme with same resulte (issue). WP is running on a server with PHP 7.0.33 on Ubuntu 16.04. I use Firefox Browser.

    Thanks for the plug-in and for any help!
    Olaf

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Jordy Meow

    (@tigroumeow)

    Hello,

    I pushed a new update today (1.1.0), can you try it? Hopefully, it will fix your issue. Please let me know 🙂 Also, just to make sure, please check your PHP Error Logs if there are still issues.

    Hi Jordy,

    many thanks for your fast reply and fix. It almost works fine: I can see and edit the reusable block e.g. ad a caption and link to an image. I can refresh the gallery block. When I click on “refresh” for the page from where I edited the block (i.e. the page where I included the blog) the refreshing seems stuck (the refresh button blinks and left from the button appears “saving” for now several minutes). But the block and the page view itself seems to be refreshed and stable.

    paws up!
    Olaf

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.