WordPress.org

Forums

WP-Piwik
[resolved] 0.9.9.11 fatal PHP error (5 posts)

  1. brucedwilliams
    Member
    Posted 10 months ago #

    The newest version of WP-Piwik completely brought down two of my sites (site itself inaccessible and backend inaccessible). The problem is apparently with line 755 in wp-piwik.php according to the PHP error log (PHP Parse error: syntax error, unexpected T_STRING). This is with PHP 5.2.10.

    Is this a PHP version dependency? If so, what is the minimum PHP version that WP-Piwik supports?

    This seems to be a change from previous versions of WP-Piwik as I had been using v0.9.9.9 plugin with no issues. If the minimum supported PHP version changed between v0.9.9.9 and v0.9.9.11, could that information be added to the change log so everyone is aware of it?

    https://wordpress.org/plugins/wp-piwik/

  2. braekling
    Member
    Plugin Author

    Posted 10 months ago #

  3. brucedwilliams
    Member
    Posted 10 months ago #

    If it has been solved multiple times perhaps you could include notice in the change log that PHP 5.2 is no longer supported?

  4. braekling
    Member
    Plugin Author

    Posted 10 months ago #

    WP-Piwik documentation

    You need a running Piwik 2.0.2 or higher installation and at least view access to your stats. Also PHP 5.3 or higher is strictly required.

    Piwik requires PHP 5.3 or higher since 2.0 (release December 2013).
    WP-Piwik requires Piwik 2.0.2 or higher since 0.9.9.7 (January 2014).

    If you like I can replace this change log line...

    Update: PHP API will use namespaces (Piwik 2.x compatibility)

    ... by this one ...

    Update: PHP API will use namespaces (Piwik 2.x compatibility, PHP 5.3+ required)

    with the next release. No matter.

    But you should take care of your software, their lifetimes and their dependencies on your own, too.

  5. Larzans
    Member
    Posted 10 months ago #

    I had the same problem, it was a clients machine with a lot of plugins to backup, so i have to admit i overread the PHP requirement, so my own fault, but...

    still, a check for the PHP version and an error message would be most welcome and user friendly :)

Reply

You must log in to post.

About this Plugin

  • WP-Piwik
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.