WordPress.org

Support

Support » Plugins and Hacks » NextGEN Gallery - WordPress Gallery Plugin » [Resolved] 0 pictures successfully added. Cannot fix this no matter what I try. Help?

[Resolved] 0 pictures successfully added. Cannot fix this no matter what I try. Help?

  • Since updating to WP 3.5 I have no been able to successfully add images to any NextGENGallery gallery. At the developers’ request, I installed NGG 1.9.11 beta, which didn’t help, so I submitted a bug report, also per their request.

    I’ve searched for hours and tried pretty much everything I can find and nothing has helped.

    I’ve tweaked .htaccess. I’ve totally cleared it out. I’ve CHMOD’d all relevant folders a hundred times. I’ve manually inspected my database tables to see what’s happening, to no good end.

    I can upload the photos just fine. The images arrives in the right folder, but it’s not actually added to the gallery.

    Likewise, nothing really happens if I try to add a gallery. It acts like it takes it, but doesn’t actually do anything.

    I can rearrange image order in galleries, as well as delete whole galleries, but that’s the extent of what I can do, it seems.

    This says to me that the plugin CAN access / write to the db, and CAN access ftp without trouble. Beyond that, I cannot figure out what the problem is.

    Has anyone figured out a solution?

    http://wordpress.org/extend/plugins/nextgen-gallery/

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have this exact same problem. I’ve updated both WordPress and NextGen, deactivated all other plugins, still no good. Tried different permission levels, re-uploading the plugin.

    If it helps, it is on a Multisite.

    Same here!

    I have the same problem and fixed mine–now mine uploads fine. I have WP 3.5.1 and NextGen Gallery 1.9.10.

    WARNING DO THIS AT YOUR OWN RISK!

    You have to uninstall the plugin, deactivate it, and then reactivate it. The problem is that you will lose all your galleries. What I did was go to GALLERY > RESET/UNINSTALL > UNINSTALL PLUGIN. Then go to PLUGINS and deactivate and reactivate it. I would have to create a new gallery, then upload to that gallery, and it works fine.

    I think there is something wrong with the NextGen Gallery here. The developers are probably not keeping up yet. With WP 3.5.1 out, NGG is having problem syncing the database tables (wp_ngg_album, wp_ngg_gallery, wp_ngg_pictures). Thus, when you upload something to a gallery, no database is written. The process above basically resets your gallery structure in the database.

    hswebdev:

    Interesting solution. I wonder if you compared the table names before and after the re-install. I wonder if it’s possible to rename the tables or export them, reinstall the plugin, then use the old tables. I’m tempted to try this solution, but I’m also nervous that if I try it and it DOESN’T solve my issues, that maybe I won’t be able to restore them at all…and them I’m out of luck.

    I’ll be curious if anyone else tries this. If I resort to it, I’ll report back. Maybe between now and then NGG will be fixed.

    I managed to somehow trick the NGG plugin and WordPress and retain my galleries, the way it used to be. Of course, I backed up my database in case I want to revert back. After attempting the above, I removed the three NGG tables, then imported the backup tables in place. Now I am able to keep my original galleries and upload to them.

    This may tell us something–there is a configuration outside of the NGG tables that was modified in order to make this work (after uninstalling the plugin and deactivating/activating it). I have a couple of dev sites to test this on, so I’m going to try to repeat and rinse this.

    OK, I’ve found a very easy fix. I noticed that the uninstalling/installing of the NGG plugin changed some configurations in the database, more specifically the ‘ngg_db_version’.

    You don’t have to do any of the above. Simply change the database entry ‘ngg_db_version’ within wp_options from ‘1.5.0’ to ‘1.8.1’ (in my case). This is with WP 3.5.1 and NGG 1.9.10.

    It appears the version conflict was not updating when you updated your NGG plugin. By changing the version manually via database, it works. Weird but it works for me, and I don’t have to lose my galleries or any other configurations.

    I wanted that to work badly, but it did not work for me.

    I know this discussion is marked Resolved, but it’s not for me.

    Hey Carynorton, did you find a solution for this?

    Thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] 0 pictures successfully added. Cannot fix this no matter what I try. Help?’ is closed to new replies.
Skip to toolbar