Support » How-To and Troubleshooting » \’ backslash appears before apostrophe in comments

\’ backslash appears before apostrophe in comments

  • I’m running 2005-01-02 and when people post comments, a backslash \ appears before any apostrophe ‘ which might be in the comment. If I edit the comment I can remove them, but it seems they probably shouldn’t be added in the first place. Where is this trouble likely to be and how can I fix it?

Viewing 5 replies - 1 through 5 (of 5 total)
  • As a follow up, this also happens with double quotation marks ” as well; they show up as \” when the user saves their comment.

    Nevermind. This was being caused by LaughingLizard’s ThreeStrikesSpam plugin. I’ve temporarily disabled it until I have time to fix it.

    I think you simply will need to find the plugin and the last line will be something like:

    return $text;

    You should change it to something like:

    return stripslashes($text);

    Then again, I could be talking out of my ass.

    Ok, well mine does almost the same thing, but seems to add an extra backslash every time I save the post. How the heck do I keep it from doing that, it’s frustrating me like you wouldn’t believe!

    if you validate the XHTML of that page at http://www.w3c.org, you can see if it has any HTML errors that might be caused by a typo in the theme, comments, etc. I have had that happen before.. it added an extra “/>” too all of my posts, so I validated and then resubmitted showing the source, was able to see the line count and go back and find where the HTML in the php file had actually gotten chopped up.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘\’ backslash appears before apostrophe in comments’ is closed to new replies.