WordPress.org

Forums

\' backslash appears before apostrophe in comments (6 posts)

  1. error
    Member
    Posted 10 years ago #

    I'm running 2005-01-02 and when people post comments, a backslash \ appears before any apostrophe ' which might be in the comment. If I edit the comment I can remove them, but it seems they probably shouldn't be added in the first place. Where is this trouble likely to be and how can I fix it?

  2. error
    Member
    Posted 10 years ago #

    As a follow up, this also happens with double quotation marks " as well; they show up as \" when the user saves their comment.

  3. error
    Member
    Posted 10 years ago #

    Nevermind. This was being caused by LaughingLizard's ThreeStrikesSpam plugin. I've temporarily disabled it until I have time to fix it.

  4. navid
    Member
    Posted 10 years ago #

    I think you simply will need to find the plugin and the last line will be something like:

    return $text;

    You should change it to something like:

    return stripslashes($text);

    Then again, I could be talking out of my ass.

  5. Ornae
    Member
    Posted 9 years ago #

    Ok, well mine does almost the same thing, but seems to add an extra backslash every time I save the post. How the heck do I keep it from doing that, it's frustrating me like you wouldn't believe!

  6. estjohn
    Member
    Posted 9 years ago #

    if you validate the XHTML of that page at http://www.w3c.org, you can see if it has any HTML errors that might be caused by a typo in the theme, comments, etc. I have had that happen before.. it added an extra "/>" too all of my posts, so I validated and then resubmitted showing the source, was able to see the line count and go back and find where the HTML in the php file had actually gotten chopped up.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.