WordPress.org

Ready to get started?Download WordPress

Forums

"-" appears in front of my websites name on Google (6 posts)

  1. iondion
    Member
    Posted 2 years ago #

    Hi! I am using the latest version of WordPress and the Mantra theme. My site just got indexed by Google and I see on their results page that my site has a " - " (a small line) sign in front of the title of my site... although in WordPress I never typed the title of the site this way... I don't know how that sign entered there. It does not bother me too much but I don't know about SEO. I think it is something related with the Mantra theme programming, a line of code that automatically inserts that in front of the title. I rechecked the Mantra options panel and does not say anything about this issue.

  2. ClaytonJames
    Member
    Posted 2 years ago #

    It's going to be something that needs to be adjusted in one of your theme files. This is the function you probably want to take a look at: Function Reference/wp title The hyphen is being used for the separator: Using Separator

    Try looking in /wp-content/themes/mantra/includes/theme-seo.php for the page meta title function or something similar.

  3. iondion
    Member
    Posted 2 years ago #

    So that small line improve Seo or something?

  4. ClaytonJames
    Member
    Posted 2 years ago #

    It's pretty common to see a hyphen used as a separator between site title and post or page title. Lots of discussions and opinions on the topic.

    do separators in title tags affect seo

  5. iondion
    Member
    Posted 2 years ago #

    Man but that hyphen appears in front of my site title not after... so what purpose that line could have??

  6. ucallelse
    Member
    Posted 2 years ago #

    If you're talking about the hyphen in the Site Title and you're saying you didn't add a hyphen in the Site Title under General Settings, then follow these steps to remove it:

    1. Go to the Appearance tab and click on Editor.

    2. Select "theme-seo.php" in the list on the right

    3. Find this line:

    $filtered_title = $title.' - '.$site_name;
    It's line 15 for me.

    3. Delete the hyphen, so it looks like this:

    $filtered_title = $title.' '.$site_name;

    4. Update File

    The hyphen should be gone.

    I hope this helped. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic