Support » Plugin: Jetpack by » -10520: Jetpack: [http_request_failed] couldn't connect to host

  • Resolved myroxie


    URL: (bottom of right sidebar)

    I installed Jetpack at the end of December and tested it to see if it was working. I received a confirmation message that I had successfully subscribed. I didn’t check it again– until tonight.

    I had just told my client to announce that the site was live and I wanted to double check everything. Tried to subscribe (with a different email address) and got an error message on the front end saying that it couldn’t go through. I then checked the backend and on the widget was the -10520 error message. I have no idea how long that error has been there since I hadn’t tried to do anything with the widget since 12/27. All I know is that I have egg on my face now that the site is launched and there is no working way to subscribe to the blog. I have a support ticket in with my host, but don’t understand what has changed since it used to work. What could be causing this to happen? And more importantly, what can I do to correct it. It’s an elegant plugin. I just wish I could get it to work again. Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have follow up information. I installed the compatibility plugin and sent the results to you in your other support area. I then deactivated and reactivated Jetpack. I tried to sign up again to subscribe and I was sucessful. No error message on the front end and I received a confirmation email that I had indeed signed up.

    Then I checked the widget only to find the same error message as before.
    -10520: Jetpack: [http_request_failed] couldn’t connect to host

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    I just tried to subscribe to your site, and everything seems to be working properly. You’ll find me in your list of subscribers.

    Have you managed to solve the issue by yourself?

    Yes. I just noticed you were there. Thank you. And I noticed it seems to be working now. And the widget is no longer throwing that error. I just signed up myself (for the third time). And I just confirmed from the email I received.

    I don’t know if anything has changed behind the scenes in the interim so that it’s now working. Doesn’t feel really secure because of that. It is possible that my host did something, but no one has managed to communicate with me about it so I don’t know.

    I guess I could send out a test post, because I still don’t know if anything is being sent to subscribers.

    Is there a way to modify it so that it doesn’t say how many other subscribers there are? Maybe if there were 1000’s it would be nice to advertise that fact. But with only 7, it’s kind of pathetic.

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    I’m glad to hear you’re all set.

    If that happens again, don’t hesitate to come back here and let me know.

    Is there a way to modify it so that it doesn’t say how many other subscribers there are?

    You can hide the number of subscribers by going to Appearance > Widgets in your dashboard, and opening the widget settings.

    Thank you Jeremy. I found that setting. I sure wish I knew why it stopped working and why it started again. Without knowing the reason, it all seems pretty whimsical. I don’t know if you read any of my support tickets that I sent through the other support channel, but when I tried the debug tool it produced an “unknown” issue. Adding further to the confusion.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘-10520: Jetpack: [http_request_failed] couldn't connect to host’ is closed to new replies.