WordPress.org

Forums

[resolved] “Briefly unavailable for Scheduled maintenance. Check back in a minute” (24 posts)

  1. hallodom
    Member
    Posted 5 years ago #

    Hi,

    If anyone has had this error when updating WordPress automatically:

    “Briefly unavailable for Scheduled maintenance. Check back in a minute”

    And have been told just to simply delete a .maintanence file that gets writen in the root and can't find it this is what I did:

    The .maintenance file was never written in my root. I looked everywhere and could not find it.

    I ended up looking in the the wp-settings.php and found the HTML written in there which I deleted (just the HTML, I didn't delete any of the PHP) and now have access to my site again.

    When I logged back in this message was displyed at the top:

    “An automated WordPress update has failed to complete – please attempt the update again now.”

    Just thought I would let the world know incase someone was faced with the same problem!

  2. hallodom
    Member
    Posted 5 years ago #

    Here's the HTML I deleted

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Maintenance</title>

    </head>
    <body>
    <h1>Briefly unavailable for scheduled maintenance. Check back in a minute.</h1>
    </body>
    </html>

  3. nitinkumarjain
    Member
    Posted 5 years ago #

    You may not see the .maintenance using the ftp in windows explorer. You may have to either use some ftp tool or if your host supports ftp over web to see the file. Just delete it.

  4. hallodom
    Member
    Posted 5 years ago #

    Hi, thanks for the tip. I was using FileZilla to browse my website root directory. Very odd!

  5. mikeboy3
    Member
    Posted 5 years ago #

    Th same happens with .htaccess, some ftp managers cannot display these files.

  6. hmillar
    Member
    Posted 4 years ago #

    its a hidden file - in filezilla go server>force showing hidden files the you will see the .maintenance file

  7. illustrata
    Member
    Posted 4 years ago #

    I have no hidden/invisible .maintenance file (that's what gives me the message “An automated WordPress update has failed to complete – please attempt the update again now,” right?)

    How do I get rid of the "Briefly unavailable for scheduled maintenance. Check back in a minute" message?

    I wish automatic updates were automatic. ;)

  8. dandr69
    Member
    Posted 4 years ago #

    This is the most CRAZY idea in the world. Now every blog crashes from time to time and displays this stupid message.
    It used to be so simple before! I hate this maintenance stuff.

  9. christopherross
    Member
    Posted 4 years ago #

    an easy fix for people having problems with the maintenance (my test servers seem voiltile with this 'feature' is to open wp-settings.php and comment out the following line:

    // Check if we're in maintenance mode.
    wp_maintenance();

    it's on line 50, simply make it:

    // Check if we're in maintenance mode.
    // wp_maintenance();
  10. raskhan
    Member
    Posted 4 years ago #

    Thanks for the post, I updated my contact 7 plug-in and it got stock on the maintenance mode.commenting out the wp_maintenance fixed the issue .

    Thanks a lot Chris

  11. lisa0721
    Member
    Posted 4 years ago #

    Same thing happened to me with the same plug-in update. I did the same thing with the wp-settings.php and it worked fine.

  12. wimmas
    Member
    Posted 4 years ago #

    WordPress Lesson 1: Remember that Auto Maintenance is NOT Auto Maintenance. My Real Estate Blog http://www.realestateauction.co.za showed a blank admin page after Auto Update. The following worked for me:

    Delete all unused themes
    Delete all unused Plugins
    Go to Plugins page
    Select all plugins
    De-Activate all plugs
    Activate them one by one starting with the most important plugins first
    As you go down your list you might find a plugin that results in a blank admin page. Go FTP and rename the folder of the offending plugin. Back to WP and F5 - Admin will fire up again. You will have to do some code hunting to find the conflict.

    Good Luck

  13. CajuCLC
    Member
    Posted 4 years ago #

    Where can we change text to be showed???

  14. Glamdering
    Member
    Posted 4 years ago #

    Thanks all. Had this happen with the 3.0.1 update on 2 of 4 sites. Had one time out twice and had to re-peat the process, but eventually it worked.

    Was able to just delete the .maintenance file after making it visible following the directions above.

  15. xXxLiLxSm0k3xXx
    Member
    Posted 4 years ago #

    The updates never work for me, and if i try to restore my site, or reinstall wordpress it never works. now i tried to update it to 3.0.1 and my site refused it, and said it can't copy some folder, now it says maintenance mode. I cant even sign in? What shall I do?

  16. wethead
    Member
    Posted 4 years ago #

    @xXxLiLxSm0k3xXx

    I had this issue as well. So what I did was just re uploaded the wordpress files manually through FTP.

    All of the files EXCEPT the wp-content folder.

    Hope this helps you,

  17. jay_nw
    Member
    Posted 4 years ago #

    I had the similar problem when doing Auto upgrade.

    To FIX it all you have to do is simply delete the .maintenance file from the blog root directory ( or Rename it)

  18. hatnaa
    Member
    Posted 4 years ago #

    jay_nw Thank you :)

  19. BayouGirl
    Member
    Posted 4 years ago #

    The wp_settings.php fixed it--Thank you so much!

  20. jojonemo
    Member
    Posted 4 years ago #

    I could not find the .maintenance file in FireFTP even with all the hidden files showing. So I tried Christopher's comment fix in wp_settings.php and it worked like a charm. Thanks, Chris!!

  21. itsbarry
    Member
    Posted 4 years ago #

    My 3.0.3 upgrade failed.

    I couldn't find the .maintenance file. I even opened a shell with putty, but there was nothing there.

    To fix, I deleted a folder called "upgrade" that was inside the wp-content folder.

    Next I logged into the back end as usual and tried to reapply the upgrade. It completely reinstalled wordpress. My site was fine. All the content was intact.

    First time this has happened to me, glad the fix was so easy.

    Don't despair! Easy to fix.

  22. ians12
    Member
    Posted 4 years ago #

    I deleted that upgrade folder and tried it again got this

    Downloading update from http://wordpress.org/wordpress-3.0.3.zip…
    
    Unpacking the update…
    
    Verifying the unpacked files…
    
    Installing the latest version…
    
    Could not copy file.: /public_html/blog/wp-admin/css/theme-editor.dev.css
    
    Installation Failed

    Which leaves it in maintenance mode as above

  23. Garry Claridge
    Member
    Posted 4 years ago #

    I am receiving the same error message as ians12 :(
    Tried plenty of the suggested solutions. I have SSH access and total control of the site.

    Will keep trying.

  24. ians12
    Member
    Posted 4 years ago #

    I think there is a bug in this new version update package.

    I tried it again with permissions on that folder/file set to 777 and it still says "could not copy file".

Topic Closed

This topic has been closed to new replies.

About this Topic