Support » Plugin: Event Tickets » 📣Event Tickets 4.12.0

  • Plugin Contributor Courtney Engle Robertson

    (@courane01)


    Happy release day! We are shipping a number of small fixes in this release. Specifically, you will notice a minor change to our Who’s Attending feature and the Public Attendees API security prompt.

    If the Who’s Attending feature is not displayed on a published event, users will not have a prompt to opt-out of the Public Attendees List — no need to opt out of something that isn’t there, right? We’re also taking a safe approach when the Who’s Attending feature is enabled after users have already registered for the event and treating them as opted out by default. They’ll still have a chance to opt back when revisiting the event.

    This is a minor release that should be smooth sailing when updating. That said, it’s always a good idea to backup your site and test changes in a development environment before installing this on your live site, as you would with any other WordPress update.

    Here are the detailed changes included in this release:

    • Feature – We’ve moved the management of shortcodes to the same common library that powers the rest of our plugins and add-ons. This will help Event Tickets users (not just Event Tickets Plus) make use of some of our extensions, like the Event Tickets shortcodes.
    • Fix – You know how it’s possible to create a custom attendee registration page using the [tribe_attendee_registration] shortcode? Well, that was overriding all of the content on the page with the content created by throw shortcode. We’ve corrected that so the shortcode can now be used with page content. 
    • Fix – When a user reaches checkout, we check to see if all attendee registration information has been completed. If there are any attendee registration fields missing, we prompt users to complete these with a notice. Unfortunately, that notice was appearing at unnecessary times, creating some confusion. We’ve updated the notice template to display content only when there’s information and removed the “Whoops” title for the Attendee Registration page notice.
    • Fix – Those of you using the new calendar view designs and wanting to override the cost in photo view may have encountered an issue where your template overrides weren’t working. We’ve updated file path in the docblocks of the templates for The Events Calendar new views to make sure your custom templates work as expected.
    • Fix – We updated the position of the tribe_tickets_ticket_add action so it receives the ticket data on ticket creation, which prevents it from conflicting with other actions.
    • Fix – We’ve removed the type="submit" attribute from the button element in the templates that contain the + and – buttons for adding and removing tickets to an order. That helps align the buttons in the ticket form.
    • Fix – Users noticed that their price totals added to zero if the ticket prices did not have a decimal separator. We corrected the Total value when the WooCommerce options for currency are empty (specifically, the thousand and decimal separators and the number of decimals).
    • Fix – When using WordPress versions before 5.0, pressing the + button to add a ticket returned no results. In other words, no ticket would be added to the cart. We corrected dependencies for the tickets block’s JavaScript so the block works correctly in earlier versions of WordPress.
    • Fix – When translating our plugins, you’ll want to use your custom .mo translation file before the system generated .mo file, so that custom translations are displayed correctly. To correct the load order, we now the load plugin text domain on the new tribe_load_text_domains action hook, which fires on init instead of on the plugins_loaded hook.
    • Fix – As part of correcting the total available tickets and shared capacity issues, we are deprecating \Tribe__Tickets__Tickets_Handler::get_total_event_capacity() and replacing it with tribe_get_event_capacity(). This method returns the correct count.
    • Fix – As part of the changes to the Public attendee list prompt, we are kicking off a background migration when updating to Event Tickets 4.12. This will fix ticket-supported posts that use the attendees list block or the attendees list shortcode included in Event Tickets Plus so those attendees appear in the REST API properly.
    • Fix – When viewing the Events page in another language, users noticed if that the date selector did not translate and reduced the size of the browser viewport, which messed with the plugin’s mobile and tablet breakpoints. We’ve cleared the views HTML cache on language settings changes to ensure we don’t mix up translated strings.
    • Fix – To improve compatibility with the WordpPress 5.4 block editor, we’ve added new module CSS class called .block-editor-inner-blocks.
    • Fix – Our Skeleton Style (Events → Settings → Display → Default stylesheet used for events templates) needed a few tweaks to be more compatible with the Divi theme. We’ve added a style override for <ul> elements due to the way the theme applies ID to them.
    • Fix – As part of our work improving plugin translation functionality, we’ve changed the way we load the text domain so it occurs on the ‘init’ hook instead of ‘plugins_loaded’. We also added a new tribe_load_text_domains action hook for our other plugins so they can take advantage of this change as well.
    • Tweak – While modifying the Who’s Attending feauture, we added a method that returns whether events are being served through Blocks or the Classic Editor.
    • Tweak – Getting fast and accurate support matters a ton! We often ask folks to send us their system information when submitting a ticket to our support team. This gives us more precise details we can use to troubleshoot issues. We went ahead and added homepage settings to the report to give us even more details we can use to help you out.
    • Tweak – We’ve had requests for a filter that can turn off the past events view in the calendar. We added the tribe_template_done filter for this. It allows you to disable a template before rendering it.
    • Tweak – We noticed that visiting the “My Tickets” page on an event caused a fatal error if the ticket was created with either WooCommerce or Easy Digital Downloads and then either of those plugins were later deactivated. We consolidated some duplicate code for getting tickets for each ticket provider to prevent that error.
    • Tweak – The “Sold Out” message for tickets wasn’t properly displaying on the updated calendar views that shipped with The Events Calendar 5.0. We’ve corrected that so the message displays anywhere the price is. 
    • Tweak – Then attendee REST endpoint now returns 401 (unauthorized) if Event Tickets Plus is not loaded.
    • Tweak – Ever want to add some descriptive text about a ticket after the price? Well, hey, you can! A “Price Suffix” is text that displays after the product price, showing details related to the price of the product. WooCommerce has a method for displaying suffice text and we’ve integrated it in the tickets block when you have the WooCommerce tax feature enabled. 
    • Tweak – When using Event Tickets Plus, the checkbox for users to “Hide my attendee data from public view” will no longer show up in the ticket form if the “Attendees List” is not being used on the event.
    • Hookshttps://docs.theeventscalendar.com/reference/since/event.tickets.plus4.12.0/
    • Languages0 new strings added, 329 updated, 10 fuzzied, and 58 obsoleted

    Next up, we’re making progress on the next major feature release for Event Tickets and can’t wait to get that out to you. In the meantime, please update safely as you would with any other WordPress, theme or plugin update and be sure to let us know if you run into any other issues.

    We have a Known Issues page for you to reference so you can see what’s already on our radar for a fix.

    Check out a detailed description of all of the changes in this release in our official release notes here 👉 https://theeventscalendar.com/release-notes/event-tickets/event-tickets-4-12-0 👈

  • The topic ‘📣Event Tickets 4.12.0’ is closed to new replies.