Support » Plugin: Security & Malware scan by CleanTalk » PHP Warning with WP CLI

  • Resolved DreamOn11

    (@dreamon11)


    Hi,

    When using WP CLI commands such as wp option get wp_template_root, the plugin return warnings which prevent to get expected data from external scripts:

    admin@xxx:/srv/www/xxx.net/current$ wp option get wp_template_root
    PHP Warning:  Cannot modify header information - headers already sent by (output started at /srv/www/xxx.net/releases/20170613160055/web/app/plugins/cleantalk-spam-protect/cleantalk-sfw.class.php:1) in /srv/www/xxx.net/releases/20170613160055/web/app/plugins/security-malware-firewall/security-malware-firewall.php on line 149
    Warning: Cannot modify header information - headers already sent by (output started at /srv/www/xxx.net/releases/20170613160055/web/app/plugins/cleantalk-spam-protect/cleantalk-sfw.class.php:1) in /srv/www/xxx.net/releases/20170613160055/web/app/plugins/security-malware-firewall/security-malware-firewall.php on line 149

    Can you fix it?

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support SergeM

    (@serge00)

    Hello.

    Thank you for your letter.

    We are sorry for the inconveniences.

    We will look into this issue and fix it as soon as possible. It will take 1-2 day.

    Please, wait.

    Your CleanTalk Control Panel: [ https://cleantalk.org/my/ ].

    Best regards.

    Thanks! 🙂

    Plugin Author Safronik

    (@safronik)

    Hello,

    As far as we know WordPress doesn’t have option called “wp_template_root” (same for WPMS).
    Please, check your command. Try something like this “wp option get cron”.
    We have tested it and everything seems fine in our test environment.

    It looks like plugin’s file outputs something, may be the file was modified.

    Any way could you update the plugin and try one more time. Also try to disable the CleanTalk’s plugins (Security, Antispam) and try without them.

    Please, contact us.

    Hi Safronik,

    I just tested command wp option get wp_template_root at the moment and… problem is gone oO

    Sorry for the inconvenience, I don’t know why I have the problem two days ago. I can now carry on my project!

    Thanks for help!

    • This reply was modified 2 years, 7 months ago by DreamOn11.
    Plugin Support amagsumov

    (@amagsumov)

    You are welcome.

    Contact us any time.

    Best regards.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘PHP Warning with WP CLI’ is closed to new replies.