Support » Plugin: Shinobi Reviews » レビューの投稿ができない

  • Resolved relight1990

    (@relight1990)


    はじめまして。画像付きレビュー投稿ができるプラグインを探していたところ、
    こちらのプラグインを見つけてインストールさせていただきました。ありがとうございます。

    レビュー投稿テストを実行しようとしたところ、
    投稿ボタンを押すと「レビューの保存に失敗しました。」と表示が出ます。

    他の方の質問への回答にあったように、
    Twenty Twentyテーマでの実行、他プラグインを無効化しての実行も試みましたが同様の結果でした。

    解決策がありましたらご教示お願い致します。

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Shinobi Works

    (@shinobiworks)

    はじめまして。ご利用いただきありがとうございます。
    以前ご質問いただいた方と同様、データベースへの保存に失敗しているようですね。
    「デフォルトテーマ適用&シノビレビュー以外のプラグイン全停止」でエラーが発生すると。
    そうですね…こちらでエラーが再現できないので、ピンポイントで回答できないのですが、「キャッシュ」か「サーバー」が怪しいでしょうか。
    ちなみに、実行環境(レンタルサーバーやPHPバージョン、キャッシュ機能)はどのようになっていますか?
    また、(キャッシュの回避のためにも)一度違うブラウザでお試しいただけますでしょうか?

    Thread Starter relight1990

    (@relight1990)

    返信いただきありがとうございます。

    実行環境は、
    レンタルサーバー:Xサーバー
    PHPバージョン:PHP7.4.13
    となります。

    キャッシュ回避として、プライベートモードを含むChrome/Microsoft edge/Firefoxで試しましたが、
    「レビューの保存に失敗しました。」という表示でした。

    他に解決策がありましたらご教示お願い致します。

    Plugin Author Shinobi Works

    (@shinobiworks)

    状況ご共有いただきありがとうございます。大変助かります。
    当該環境での検証ができました。7.4系と、8系で、確かにエラーが発生しました。ご迷惑おかけしております。

    エックスサーバーはシェアも高いため、何かしら対応しなければとは思っているのですが、実は、ローカル環境(開発時の環境)とConoHa WING(本番環境)でエラーを再現できないため、具体的にどこで問題になっているのか把握できておりません。

    レンタルサーバー側の問題はあまり考えられないので、シノビレビュー側の問題になるかとは思っておりますが、検証が必要になります。リソースの関係で、しばらくお時間いただくと思いますが、ご理解いただければ幸いです。

    取り急ぎ、エックスサーバーの7.2系ではエラーが発生しないことは確認しているので、PHPのバージョンに依存しているサイト環境でなければお試しください。

    また、他に検証材料などございましたら、ぜひご共有いただければ助かります。サポートへの投稿、重ねて感謝いたします。

    Thread Starter relight1990

    (@relight1990)

    検証いただきありがとうございました。

    ひとまず当方だけに起こるエラーではないと分かって幸いです。
    引き続き検証いただきエラーを解決していただけるとありがたいです。

    よろしくお願い致します。

    Plugin Author Shinobi Works

    (@shinobiworks)

    こんにちは。
    お返事遅くなりました。

    先ほど、当該不具合を解消したバージョン1.4.7を公開しました。
    アップロード後、正常に投稿できることを確認できるかと思います。

    不具合箇所についてですが、ユーザー情報の取得部分で不具合が発生しておりました。
    しばらく前のバージョンより当該情報を使用していていなかったので、プログラムを削除して対応しました。

    引き続き、気がかり点などございましたらサポートフォーラムをご利用ください。
    この度はご利用ありがとうございました!

    Thread Starter relight1990

    (@relight1990)

    おはようございます。

    新しいバージョンへと更新し、テスト投稿を行ってみたところ正常に作業確認ができました。
    拡張も検討したいと思っております。

    ご対応いただき本当にありがとうございました。

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.