Support » Plugin: Constant Contact for WordPress » ​Hi, I need to update my server to PHP7 and there are errors with the Eden theme

  • ​Hi, I need to update my server to PHP7 and there are errors with the Eden theme when I run WP Engine’s PHP7 compatibility checker, please could you fix these. The errors are:

    FILE: /nas/content/live/superconnect/wp-content/plugins/constant-contact-api/classes/class.kwscampaign.php
    ————————————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————————
    48 | ERROR | ‘clone’ is a reserved keyword introduced in PHP version 5.0 and cannot be invoked as a function (T_CLONE)
    ————————————————————————————————————————

    FILE: /nas/content/live/superconnect/wp-content/plugins/constant-contact-api/classes/class.kwscontactlist.php
    ————————————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————————
    45 | ERROR | ‘clone’ is a reserved keyword introduced in PHP version 5.0 and cannot be invoked as a function (T_CLONE)
    ————————————————————————————————————————

    FILE: /nas/content/live/superconnect/wp-content/plugins/constant-contact-api/classes/class.kwscontact.php
    ————————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————————-
    127 | ERROR | ‘clone’ is a reserved keyword introduced in PHP version 5.0 and cannot be invoked as a function (T_CLONE)
    ————————————————————————————————————————-

    FILE: /nas/content/live/superconnect/wp-content/plugins/constant-contact-api/vendor/guzzlehttp/promises/src/functions.php
    —————————————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————————————————
    485 | WARNING | Function name “__next_coroutine” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    —————————————————————————————————————————————————​

    Many thanks

Viewing 1 replies (of 1 total)
  • Sorry, I copied and pasted wrongly – I’m referring to the Constant Plugin, not the Eden theme!

Viewing 1 replies (of 1 total)
  • The topic ‘​Hi, I need to update my server to PHP7 and there are errors with the Eden theme’ is closed to new replies.