Support » Plugin: پلاگین پرداخت دلخواه » خطا :برای اطلاعات رمزنگاری مقدار لازم است.

  • Resolved matlabiir

    (@matlabiir)


    سلام
    این پلاگین با درگاه ملت و ذرین پال بخوبی کار میکنه
    اما با درگاه ملی مشکل داره
    من از یک فرد خبره پرسیدم چنین پیشنهادی دادن:
    به جای
    mcrypt_encrypt
    از
    openssl_encrypt
    استفاده کنن
    ————
    خطایی که به من میده تو پی اچ پی:
    Warning: mcrypt_encrypt(): Key of size 10 not supported by this algorithm. Only keys of size 24 supported in /home/matlabii/public_html/wp-content/plugins/pardakht-delkhah/gateways/class-cupri-melli-gateway.php on line 101

    ممنون میشم راهنمایی یا اصلاح بفرمایید

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Omid Shamloo

    (@goback2)

    علیکم السلام.
    اتفاقا روی ملی هم الان فعاله و داره کار میکنه.
    مورد شما احتمالا مورد وابستگی به محیط هاست هست.
    با این حال چشم.
    اگر از سمت پلاگین این مورد قابل حل بود اقدام میشه ان شاءالله
    درگاه شما روی سداد قدیم هست یا جدید؟
    این کد بر مبنای درگاه جدید نوشته شده

    matlabiir

    (@matlabiir)

    درود
    من افزونه درگاه بانک ملی رو دارم و روی ووکامرس داره بخوبی جواب میده
    اما این افزونه درگاه دلخواه جواب نمیده
    البته با درگاه ملت و ذرین پال درسته و خطایی نداره

    از درگاه جدید بانک ملی استفاده می کنم

    تو تلگرام با این آیدی هستم. اگر اطلاعات بیشتری خواستین یا دسترسی به وردپرس:
    @matlabcoder

    Plugin Author Omid Shamloo

    (@goback2)

    این مورد روی نسخه های خاص php رخ میداد که حل شد.

    مشکل در آپدیت جدید این افزونه رفع شده
    ممنون از پشتیبانی و افزونه خوبتون

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘خطا :برای اطلاعات رمزنگاری مقدار لازم است.’ is closed to new replies.