Support » Plugin: WPGlobus - Multilingual Everything! » Проблемы с редактированием сайта

  • Resolved ggreta

    (@ggreta)


    Здравствуйте!
    У меня возникли проблемы с редактированием сайта – не могу сохранять изменения на сайте, обновлять плагины и т.д.

    При любом действии появляется такое сообщение:

    There has been a critical error on your website. Please check your site admin email inbox for instructions.

    От WordPress пришло следующее письмо, привожу только его часть:

    Тема: Your Site is Experiencing a Technical Issue

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with one of your plugins, WPGlobus.

    Если нужно, я пришлю Error Details.

    Я обращалась в службу поддержки WordPress, но они ничем не смогли помочь.
    Пожалуйста, помогите разобраться с этой проблемой, иначе я не могу работать с сайтом.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Contributor Alex Gor

    (@alexgff)

    @ggreta Если нужно, я пришлю Error Details
    нужно

    Error Details
    =============
    An error of type E_ERROR was caused in line 141 of the file /home/***/public_html/wp-content/plugins/wpglobus/includes/admin/meta/class-wpglobus-meta.php. Error message: Uncaught Error: Call to undefined function get_metadata_raw() in /home/***/public_html/wp-content/plugins/wpglobus/includes/admin/meta/class-wpglobus-meta.php:141
    Stack trace:
    #0 /home/***/public_html/wp-includes/class-wp-hook.php(288): WPGlobus_Meta::filter__update_post_metadata(NULL, 4674, ‘_yoast_wpseo_fo…’, ”, ”)
    #1 /home/***/public_html/wp-includes/plugin.php(206): WP_Hook->apply_filters(NULL, Array)
    #2 /home/***/public_html/wp-includes/meta.php(202): apply_filters(‘update_post_met…’, NULL, 4674, ‘_yoast_wpseo_fo…’, ”, ”)
    #3 /home/***/public_html/wp-includes/post.php(2139): update_metadata(‘post’, 4674, ‘_yoast_wpseo_fo…’, ”, ”)
    #4 /home/***/public_html/wp-content/plugins/wordpress-seo/inc/class-wpseo-meta.php(658): update_post_meta(4674, ‘_yoast_wpseo_fo…’, ”)
    #5 /home/***/public_html/wp-content/plugins/wordpress-seo/admin/metabox/class-metabox.php(766): WPSEO_Meta::set_value(‘focuskw’, ”, 4674)
    #6 /home/***/public_html/wp-includes/class-wp-hook.php(290)

    Plugin Contributor Alex Gor

    (@alexgff)

    Обновите WordPress до версии 5.5

    Это невозможно, выкидывает с сообщением There has been a critical error on your website.

    На страницу плагинов тоже зайти не могу.

    Plugin Contributor Alex Gor

    (@alexgff)

    Удалите WPGlobus через FTP.

    Хороший совет, но мне во-первых, WPGlobus нужен для работы сайта, а во-вторых, весь текст, написанный на русском языке можнт пропасть или просто проявится на сайте, там где он быть не должен.
    Других вариантов нет?

    Plugin Contributor Alex Gor

    (@alexgff)

    OMG
    1. удаляете WPGlobus via FTP
    2. обновляете WordPress до 5.5
    3. устанавливаете WPGlobus из репозитория
    Установки WPGlobus и посты в БД не будут затронуты

    из репозитория – что это, не могли бы пояснить?
    где гарантии, что сайт не полетит?

    Plugin Contributor Alex Gor

    (@alexgff)

    Репозиторий здесь

    Сайты не летают
    WPGlobus 2.5 тестируется с WordPress 5.5

    “Сайты не летают” – все может быть, вы прекрасно меня поняли. А вот я вас нет. То есть, мне придется заново скачать плагин и установить его? Не могли бы вы быть немного более многословным, спасибо

    Plugin Contributor Alex Gor

    (@alexgff)

    Moderator Sergey Biryukov

    (@sergeybiryukov)

    WordPress Dev

    Обновите WordPress до версии 5.5

    А почему у вас на странице плагина заявлена совместимость с WordPress 5.0 или выше? Стоит тогда указать, что требуется WP 5.5 или выше, чтобы пользователям старых версий не приходили несовместимые обновления 🙂

    ggreta

    (@ggreta)

    1. удаляете WPGlobus via FTP – удалила
    2. обновляете WordPress до 5.5 – обновила до 5.5.3
    3. устанавливаете WPGlobus из репозитория – невозможно это сделать, так как даже после выполнения первых двух шагов я не могу попасть в панель управления сайта.

    ggreta

    (@ggreta)

    спасибо за помощь, все восстановила

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.