Support » Plugin: WordPress Popular Posts » После обновления перестал показать посты

  • Resolved rianovost

    (@suryano11)


    Original text:

    сегодня утром вышел обновление плагина, хотя именно данный плагин работал отлично, все-таки решил обновить и перестал показывать в записи виджете (виджет у меня на боковой колонке под радио), сейчас выглядит так, как будто нет виджета, хотя в админке всё на месте, ошибок нет. Я попросил подправить recently а вы тут поковыряли

    Yandex translate : this morning, the plugin update was released, although this plugin worked perfectly, I still decided to update it and stopped showing it in the widget entry (the widget is on the side column under the radio), now it looks as if there is no widget, although everything is in place in the admin panel, there are no errors. I asked you to fix it recently and you’ve been poking around

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Héctor Cabrera

    (@hcabrera)

    Hi @suryano11,

    There’s likely a conflict with one your other plugins. Please go to Settings > WordPress Popular Posts, click on the Debug link located at the top center of your screen, then take a screenshot of the information shown there and share it here so I can have a look (you can upload your screenshot to postimages.org or prnt.sc.)

    Thread Starter rianovost

    (@suryano11)

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Thanks!

    The problem is most likely caused due to a conflict with WP Optimize. Please check this FAQ: Is WordPress Popular Posts compatible with plugins that minify/bundle JavaScript code?

    Thread Starter rianovost

    (@suryano11)

    The problem was solved according to your instructions, thank you. Please see recently how to fix it. And here you mark the issue as resolved

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Actually, while that problem was indeed fixed there seems to be another one.

    I checked your site and it seems that something is redirecting WPP’s requests to the REST API. I’m seeing a HTTP 301 response (Moved Permanently) on the console log, it should be 200 (OK) or 201 (Created) depending on the type of request.

    Please double check the redirection rules you set up on your website (.htaccess? A plugin?) to make sure that WPP can work properly.

    Thread Starter rianovost

    (@suryano11)

    And I have not found a redirect anywhere, even the link can be opened https://rianovost.ru/wp-json/wordpress-popular-posts/v1/popular-posts/widget/2

    But in any case, tell me how to fix the situation, I did not set up redirects in seo plugins, not in htacess

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Sorry, no idea where that redirection is coming from. It could be coming from a plugin or your .htaccess file (although you said there are no redirection rules there.) The redirection is happening though, try viewing your website via Incognito Mode (or log out from the WP Dashboard) and you’ll see that your popular posts widget isn’t loading due to said 301 Moved Permanently redirection.

    Thread Starter rianovost

    (@suryano11)

    You are right, in incognito mode, the address is not available, and the widget is not visible. But how to get out of the situation? I have the only thing in robots. txt disable wp-json

    Htacess :

    # BEGIN WordPress
    # Директивы (строки) между <code>BEGIN WordPress</code> и <code>END WordPress</code>
    # созданы автоматически и подлежат изменению только через фильтры WordPress.
    # Сделанные вручную изменения между этими маркерами будут перезаписаны.
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    	RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    	RewriteBase /
    	RewriteRule ^index\.php$ - [L]
    	RewriteCond %{REQUEST_FILENAME} !-f
    	RewriteCond %{REQUEST_FILENAME} !-d
    	RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    Plugin Author Héctor Cabrera

    (@hcabrera)

    Well, any theme or plugin that uses the REST API (like WordPress Popular Posts and many others) need access to /wp-json (that’s where the REST API lives :P) so maybe that’s what’s causing the problem. Try removing that from your robots.txt file and see if that fixes it.

    Thread Starter rianovost

    (@suryano11)

    Thread Starter rianovost

    (@suryano11)

    It turns out that clearfy disabled wp-json I unchecked the switch, but it didn’t work, I was forced to deactivate the plugin, then activated it, but didn’t enable “disable json”. (I only need clearfy to transliterate links). The issue is resolved, thank you! Please do not forget to resolve the issue of duplication (recently)

    • This reply was modified 1 year, 9 months ago by rianovost.
    Thread Starter rianovost

    (@suryano11)

    Спасибо 🤝 👍

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘После обновления перестал показать посты’ is closed to new replies.