Support » Plugin: wpForo Forum » Первое знакомство и ошибки

  • Нужен был форум. Стоял BBPress, но не подошел. Искал замену. По поиску forums первым вышел WpFORO. Поставил. Первый же запуск и ошибка – почему то футер перешел в форум или еще куда-то – вобщем выглядит это как смесь футера и форума…

    Апдейт

    После найденной и исправленной ошибки (зачем-то с корня сайта брал сохраненный на всякий случай старый footer.php) – заработал на тестовой странице. Пока поднял оценку до 4. Посмотрим в полевых условиях. Остались замечания влияющие на дизайн.

    • This topic was modified 2 years, 9 months ago by  montashov.
Viewing 15 replies - 1 through 15 (of 26 total)
  • Plugin Author gVectors Team

    (@gvectors-team)

    Hi montashov,
    We’re sorry to hear that your theme conflicts with wpForo. This is something unpredictable and we do our best to avoid such problems as much as possible. We could check the conflict point and fix it. Just install it again and leave URL to forum page.

    Plugin Author gVectors Team

    (@gvectors-team)

    Thank you montashov.
    But the page is closed for guests.

    Извините, но этот раздел предназначен исключительно для администрации

    As you guess we visit this page as guest. Please open it for guests. If you can’t it open just contact us using support[at]gvectors.com email address.

    I opened. I forgot that for all closed normally.

    I opened. I forgot that for all closed normally.

    Plugin Author gVectors Team

    (@gvectors-team)

    Ok, the problem comes from your Sidebar/Widget/Page Template/ configuration. We see you’ve made some changes. Please do these and let us know:

    1. Please edit the forum page:

    2. Change Page template to a template without sidebar, full width (Страницы без сайдбара):

    3. Navigate to Внешний вид > Виджеты and put some widgets to wpForo Sidebar:

    4. Then navigate to Форумы > Настройки > Детали and change options to these:
    Да – Показать статистику форума (just for testing, then you can turn it off)
    Да – Включение выходного буфера (just for testing, then you can turn it off)
    Да – Помогите wpForo расти, показать инфо о плагине (just for testing, then you can turn it off)

    The problem is not solved. The plugin modifies the footer – it’s not right. Footer part of the site design.

    It is not clear where taken footer. You can see – on the footer of the plugin version 1.1 – and 1.2 in the footer site. This is some old footer and it is unclear where it takes plugin.

    • This reply was modified 2 years, 9 months ago by  montashov.

    page with no sidebar

    Plugin Author gVectors Team

    (@gvectors-team)

    I don’t see the #4 of my correction suggestions, please do that, it’s important:
    4. Then navigate to Форумы > Настройки > Детали and change options to these:
    Да – Показать статистику форума (just for testing, then you can turn it off)
    Да – Включение выходного буфера (just for testing, then you can turn it off)
    Да – Помогите wpForo расти, показать инфо о плагине (just for testing, then you can turn it off)

    Also:
    The footer of forum page and the footer of all other pages of your website are different, please check the page layout settings below the content editor. There should be other settings on the screen you’ve attached. I don’t see WebMoney banners on other page footers but I see that on forum page, it seems the footer of wpForo page is not the right one, make sure it the same as others.

    In any case, if this doesn’t help just contact us via support[at]gvectors.com for deeper support, we’ll fix it very easy.

    “I don’t see the #4 of my correction suggestions”

    ok – can look at.

    “The footer of forum page and the footer of all other pages of your website are different,”

    That’s the question. Where and what footer takes your plugin if footer on all pages of one.

    • This reply was modified 2 years, 9 months ago by  montashov.
    Plugin Author gVectors Team

    (@gvectors-team)

    Please delete cache if you do some changes, we don’t see that, we’re guests.
    Page footer settings should be below the page editor. wpForo creates a simple page on installation, but it can’t set all necessary settings of page layout. Please see this screenshot:

    If you don’t have other settings below this, you should delete this page, create a new page, then put [wpforo] shortcode in content, copy the slug of the new page and past it in Forums > Settings > general > Forum base URL option

    login support[at]gvectors.com instead of “at” write @
    pass 123456

    On page – no nonsense
    1
    2
    34

    Create a new page?

    The problem was the following:
    the plugin takes the footer.php is not in the folder with the theme, and from the main folder. In the main folder I put old version of the footer.php. Plugin took some reason this old file.

    Main folder: site/…
    Folder with the theme: site/wp-content/themes/…

    Plugin file does not take from a theme folder

    • This reply was modified 2 years, 9 months ago by  montashov.
    • This reply was modified 2 years, 9 months ago by  montashov.
    Plugin Author gVectors Team

    (@gvectors-team)

    wpForo doesn’t have any function to get any footer. This comes from page. Please create a new page, test it if it’s good and then attach forum to this page using this instruction:
    1. delete current page,
    2. In new page put [wpforo] shortcode in content,
    3. copy the slug of the new page and past it in Forums > Settings > general > Forum base URL option.

    There is no need. Everything worked. Value to delete the footer.php from the main folder and the error is over.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Первое знакомство и ошибки’ is closed to new replies.