• Resolved kotyarashop

    (@kotyarashop)


    Вечер добрый.
    В Интернет Эксплорере вижу поля плагина независимо от выбранного способа доставки.
    При нажатии поля области ничего не происходит, даже если выбран нужный способ доставки.
    При этом в Хроме все нормально работает.
    Скрин: http://i.piccy.info/i9/27869a2e42b623a37ee0ef07b42fbb07/1571331740/74405/1342955/Bez_ymeny_1.jpg

    Это у меня на сайте ошибка или в плагине?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Информация из лога ошибок:
    [Thu Oct 17 20:06:06 2019] [warn] [client ***] mod_fcgid: stderr: get_option, referer: https://kotyara.com.ua/checkout/
    [Thu Oct 17 20:06:06 2019] [warn] [client 95.67.106.210] mod_fcgid: stderr: PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘kirillbdev\\WCUkrShipping\\Classes\\CheckoutValidator’ does not have a method ‘afterCheckoutValidation’ in /home/hhlarEi3B7aW/kotyara.hostenko.com/wp-includes/class-wp-hook.php on line 286, referer: https://kotyara.com.ua/checkout/

    Plugin Author kirillbdev

    (@kirillbdev)

    Здравствуйте. Смотрю Ваш сайт с Microsoft Edge – http://prntscr.com/pkqr13. Проблем не вижу. Какая версия IE ?

    IE 11.0.9600.18638

    Консоль ИЕ при загрузке ошибки выдает это:

    DOM7011: Код на этой странице запрещает кэширование вперед и назад. Дополнительные сведения см. по адресу http://go.microsoft.com/fwlink/?LinkID=291337
    Файл: checkout
    HTML1300: Произошел переход.
    Файл: checkout
    HTML1509: Несопоставленный закрывающий тег.
    Файл: checkout, строка: 450, столбец: 1
    SCRIPT1014: Недопустимый знак
    Файл: nova-poshta-checkout.js, строка: 31, столбец: 21

    При переходе по ссылке последней строки попадает на:
    html += <option value="${area['ref']}">${area['description']}</option>;

    Место расположения курсора: на первом знаке `

    Plugin Author kirillbdev

    (@kirillbdev)

    @kotyarashop Спасибо за обнаруженную проблему. Ближе к ночи выпущу фикс.

    Plugin Author kirillbdev

    (@kirillbdev)

    @kotyarashop Здравствуйте. Обновитесь пожалуйста до версии 1.4.5 и перепроверьте ошибку.

    Заработало, благодарю 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.