Support » Plugin: Yandex.News Feed by Teplitsa » Минимальная поддерживаемая плагином версия php

  • Resolved versusbassz

    (@versusbassz)


    После обновления с примерно 1.10.2 на 1.10.7 (текущую) посыпались fatal error:

    
    PHP Parse error:  syntax error, unexpected '[' in /..../wp-content/plugins/yandexnews-feed-by-teplitsa/inc/tst-yandex-feed-core.php on line 1087
    

    Сайт старый, работает на php 5.3.3
    На сколько понимаю, в случае плагина теперь версия минимум 5.4

    Определитесь, пожалуйста, с минимально поддерживаемой версией php для этого плагина. Лучше это прямо указывать в описании плагина и в коде загруки плагина проверять версию (и например отключаться если версия меньше нужной и выводить в admin_noticies для админов сообщение об этом). На ваше усмотрение.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Teplitsa support

    (@teplosup)

    Добрый день.
    Точный ответ по ошибке вам может дать наш программист. Но он в отпуске, выйдет только 4-го февраля и начнет смотреть задачи начиная с этого момента.
    Пока вы можете откатить версию плагина на более раннюю или обновить версию PHP.

    Thread Starter versusbassz

    (@versusbassz)

    Откатился.
    Но лучше чтобы программист посмотрел, да.

    Plugin Author Teplitsa support

    (@teplosup)

    Да, посмотрит обязательно.

    Plugin Author Denis Cherniatev

    (@denischerniatev)

    Да, все верно. В версии 1.10.7 минимальная версия PHP для работы плагина изменилась. Учтем ваши замечания в будущем релизе.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Минимальная поддерживаемая плагином версия php’ is closed to new replies.