WordPress.org

Plugin Directory

YITH Newsletter Popup

YITH Newsletter Popup gives you the ability to have a floating popup with a newsletter form in any theme. It also supports WooCommerce products.

1.0.1

  • Updated: Plugin Core Framework

1.0.0

  • Initial release

Requires: 3.5.0 or higher
Compatible up to: 4.1.4
Last Updated: 2015-1-12
Active Installs: 2,000+

Ratings

3.9 out of 5 stars

Support

0 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.