WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

XMPP Authentication

Allows users to authenticate without password via XMPP and for visitors to be filtered by XMPP verification.

The easy way is via your installed WordPress's administration pages:

  1. Click Plugins > Add New;
  2. Search for xmpp-auth;
  3. Find it in the displayed list;
  4. Click Install Now.

Alternatively, here is the old "manual" version:

  1. Upload the plugin archive to wp-content/plugins/ directory on your WordPress installation;
  2. Uncompress it by keeping it in its own sub-directory called xmpp-auth/;
  3. Activate the plugin through the 'Plugins' menu in WordPress;
  4. Configure the plugin through the appearing sub-menu XMPP Authentication under the Plugins menu;
  5. When aknowledging the configuration by pressing the Update button, login will be tested (a connection will be attempted). If anything is wrong with your configuration, you will be immediately informed.

Once installed, I would suggest to modify the configuration in Settings > Discussion > uncheck Comment author must fill out name and e-mail as they will be verified by XMPP (but the fields will stay if the user wants to add them in).

Also the new comment field (for JID) is automatically displayed if you use a recent theme (because it uses a function newly added since 3.0). If you don't see the new field after activating, don't panick. 4 solutions:

  1. the simpler: use a more recent theme. The default twentyten and twentyeleven will work perfectly without doing anything;
  2. if you don't want to change your theme, try to contact the theme writers and ask them if they could not support the generic (and now "adviced")
comment_form()

feature (they will understand); 1. you know PHP/HTML and want to do it fast: simply check the file

comments.php

of your theme. and either replace the whole form by this simpler function: <?php comment_form(); ?> yourself; 1. or if you want to do it manually, add the following code (can be modified, but what matters obviously is the id of the input field):

<p class="comment-form-email"><label for="jid" title="Jabber ID (will not be
published)"><?php _e( 'JID' ); ?></label><span class="required">*</span>
<input id="jid" name="jid" type="text" value="" size="30" aria-required="true" />
</p>

My advice is obviously to go for the first and the second solutions. The third one is really when you want to do this fast (but still you should report this to the theme writers for them to update upstream) and the fourth is a last resort if you have some very atypical comment form.

dependencies

  • PHP > 5.1.0 (for function stream_socket_enable_crypto).

  • expat library to parse XML (enabled with the --with-xml option of the php compilation).

Note for gentoo users: you must set the 'xml' USE flag.

  • OpenSSL (> 0.9.6) must be installed on the server and PHP must be built with --with-openssl.

  • OPTIONAL: if the plugin is installed on a BSD (Mac included), in order to use the SRV records on the admin JID, which is the correct way of resolving the server and port addresses for a domain, the PEAR extension NET_DNS must be installed: pear install NET_DNS (Note that it will ask to have php compiled with mhash option). If it is installed on Windows, it is not anymore useful if you have PHP 5.3.0 or later installed (under this version of PHP, you should also install the NET_DNS extension to benefit SRV records). Linux servers do not need this extension to have SRV.

Note for gentoo users: you must set the 'mhash' USE flag.

Working Platforms

This script has been tested only currently on WordPress 3.2.1 up to WordPress 3.2.1 with PHP 5.3.5 up to PHP 5.3.8, running on a GNU/Linux 64 bits (Gentoo Linux). Hopefully it should work with other software versions (not for PHP4, because of the TLS feature which is PHP5 specific. Yet if you are really interested into PHP4 compatibility and if TLS is not required for your connection, just ask me, I will try to make a compatibility layer), but I cannot guarantee. Tell me please if you tried this successfully with another configuration so that I update the known working platforms list.

At the opposite, if you find a bug or encounter an issue on some configuration, don't hesitate to tell me, and I will try and fix it.

Requires: 3.2.0 or higher
Compatible up to: 4.4.5
Last Updated: 11 months ago
Active Installs: Less than 10

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1 100,1,1 100,1,1
100,1,1