WPSC DTA Export

Description

Export orders from the WP E-Commerce Plugin as DTA File.
This file format is used in Germany to exchange information about money transactions with banks or online banking programs.
It uses the DTA class written by Hermann Stainer and Martin Schütte.
It automatically remembers the last exported order to avoid double payments.
Tested with WP E-commerce Version 3.9.

The plugin needs PHP 5+.

Translations

  • German

Credits

The WPSC DTA Export icon is adapted from the Fugue Icons of http://www.pinvoke.com/.

Screenshots

  • Administration Page

Installation

To install the plugin to the following steps

  1. Unzip the zip-file and upload the content to your WordPress Plugin directory.
  2. Activiate the plugin via the admin plugin page.

FAQ

Installation Instructions

To install the plugin to the following steps

  1. Unzip the zip-file and upload the content to your WordPress Plugin directory.
  2. Activiate the plugin via the admin plugin page.

Contributors & Developers

“WPSC DTA Export” is open source software. The following people have contributed to this plugin.

Translate “WPSC DTA Export” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

1.7.2

  • UPDATED: updated translation template using custom perl script

1.7.1

  • NEW: mobile responsive admin panel
  • UPDATE: updated function visibilities
  • UPDATE: updated translation template

1.7

  • some small fixes

1.6.9

  • some smalll fixes

1.6.8

  • BUGFIX: prevent unauthorized export
  • BUGFIX: some other small fixes

1.6.7

  • NEW: fancy jquery UI tabs for settings including smoothness theme
  • NEW: give error message if WP eCommerce Plugin is not installed or activated
  • BUGFIX: fixed notification issue upon plugin activation

1.6.6

  • BUGFIX: fixed admin_page_url() to menu_page_url()

1.6.5

  • BUGFIX: use esc_url() on URLs

1.6.4

  • BUGFIX: small fixes

1.6.3

  • NEW: small design updates
  • BUGFIX: fixed undefined indices issues

1.6.2

  • BUGFIX: stripslashes on checkout formfield labels
  • BUGFIX: stripslashes on receiver/payer names and usage

1.6.1

  • SECURITY FIX: fixed possible cross-site-scripting exploit

1.6

  • NEW: Compatible with WordPress 4.0.1 and WP E-Commerce 3.9
  • UPDATE: Use version 1.4.3 of DTA class further developed by Martin Schütte.
  • BUGFIX: escape html specialchars in $_POST variables for security

1.0 – 1.5

  • First versions for WP E-commerce 3.7.4.