WordPress.org

Plugin Directory

WP User Stylesheet Switcher

Adds a list (or multiple list) of stylesheets in the frontend to allow visitors to choose a different visual look for the website.

2.1.0

  • Add the possibility to show link text with the icon (before, after, over or under)
  • Add Serbi translations

2.0.3

  • Fix stylesheet flashes when changing page

2.0.2

  • Fix array initialization problem ("array()" instead of "[]") for older php versions (< 5.4)

2.0.1

  • Fix missing .js files

2.0.0

  • Multiple different switchers
  • No more page reload (using javascription instead of forms)
  • Preserver user choice using a cookie

1.6.1

  • Fix blank page on automatic rotation.

1.6.0

  • Fix session start condition
  • Option to have automatic theme rotation
  • Option to chose between relative or absolu path (useful for multisites)
  • Add plugin icon and banner

1.5.8

  • Fix blank option update in config page

1.5.7

  • Ignore empty options when using single switcher button

1.5.6

  • Fix blank page when upgrading
  • Add information to "Option to remove stylesheets"

1.5.5

  • Fix missing js file
  • Add explanation for the "no stylesheet" option.

1.5.4

  • Add optional single switcher button (with text or icon) to rotate between stylesheets
  • Add option to remove all styles and stylesheets.
  • Increase filename maxlength
  • Change stylesheet priority when loading them.

1.5.2

  • Fixes default stylesheet with more then five stylesheets

1.5.1

  • Adds Spanish translation

1.5.0

  • Internationalization of this plugin
  • Internal update toward OOP (class for the plugin and for the widget)

1.0.1

  • Set defaults to php function show_wp_user_stylesheet_switcher()

1.0.0

  • Possibility to choose between an icon list of a dropdown list
  • Add option to the shortcode and the widget
  • Fixes layout positioning bug with Twentythirteen theme
  • Manage uninstall to remove options/widgets

0.2.0

  • No limits for the number of stylesheets to offer.

0.1.0

  • First stable version released.

Requires: 3.6 or higher
Compatible up to: 4.2.3
Last Updated: 2015-7-27
Active Installs: 400+

Ratings

4.4 out of 5 stars

Support

1 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1
100,1,1 100,1,1 100,1,1 50,2,1 100,1,1
100,1,1 100,2,2
100,1,1
100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1